Home Download Buy Blog Forum Support

SideBar not refreshing

Re: SideBar not refreshing

Postby jps on Fri Nov 11, 2011 4:44 am

Sublime Text uses Apple's FSEvents API for file system monitoring. Outside of symlinks, I don't know what scenarios can cause it to stop reporting events.
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: SideBar not refreshing

Postby peppy on Fri Nov 11, 2011 5:57 am

Okay, I've done some further testing specifically on my saved sublime-projects. It would seem if I create the project from scratch (same destination directory, no symlinks involved in either case) it starts working correctly. Loading from the .sublime-project file refuses to pick up on changes. I'll take a further look and see if I come up with anything, but maybe this gives you a lead as to what could be happening here?

This doesn't explain configuration changes not being picked up either, but that could be a symlink issue (even though it used to work fine?).

Update: I have my old projects set to use the path of "./", so it works in both Windows and OS X. This seems to be causing the issue for me. Changing this to "." fixes the issue (and works on windows as well).

Update2: Seems the trailing slash is the problem. Same happens with my other projects that use a non-pwd relative path as well. I would say it's probably a good move to trim this slash at an application level to avoid this.
peppy
 
Posts: 52
Joined: Thu Aug 04, 2011 4:52 pm
Location: perth, australia

Re: SideBar not refreshing

Postby jps on Sat Nov 12, 2011 2:50 am

Thanks for the information peppy, I'll take a look at it
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: SideBar not refreshing

Postby misterparker on Wed Nov 16, 2011 7:58 am

I started a new project and noticed it was failing to refresh, but still refreshes on some of my other projects. I tried creating new folders moving everything. It puzzles me. I even went into a project that was refreshing fine, and added the folder that was not refreshing. And the one still wont refresh while the older one does - in the same sidebar - here is the screencast of it:
http://cl.ly/BrZW

This is killing me
misterparker
 
Posts: 1
Joined: Wed Nov 16, 2011 7:56 am

Re: SideBar not refreshing

Postby peppy on Thu Nov 17, 2011 5:29 am

Are you 100% sure that no symlinks are involved in the path to public_html in that example? I can still replicate this behaviour when the path is inside a symlink'd folder.
peppy
 
Posts: 52
Joined: Thu Aug 04, 2011 4:52 pm
Location: perth, australia

Re: SideBar not refreshing

Postby jakobud on Sun Dec 11, 2011 6:06 am

This is happening on my Windows 7 x64 workstation as well. Sublime build 2139. I have to close ST and repoen it in order for the sidebar folders/files to refresh. It only does it sometimes though. For example, I just used a web framework to generate some code and directories and they aren't showing up in the sidebar. But if I open up Explorer and go and manually create a directory in the same spot, it shows up correctly along with the auto-generated directory. Not sure how to reproduce this problem...
jakobud
 
Posts: 37
Joined: Wed Feb 17, 2010 6:05 pm

Re: SideBar not refreshing

Postby bobb.delsol on Tue Jul 09, 2013 5:59 pm

Got a solution from User echo. worked -- i'm so happy. thanks Sublime Text→Andy Jarrell

I can't find forum link to where I saw the suggested change, but there is a non-documented option to put in your user settings file. It is:



"ignore_inodes": true



I had to use it when connected to SAMBA/CIFS shares to resolve the issue. I wasn't seeing the issue for local files, just the network mounted folders. This setting still seems to work in Sublime Text 3 as when I remove it the issue comes back for those network mounted folders, but when I keep it in my user settings it works correctly. I do think it affected Sublime's ability to detect changes on the local file system (that's just anecdotal.) I didn't go to the effort to figure out how to add the setting to a sublime project file so it can be applied per project (if there is a way?).



Not sure if that is remotely helpful.
bobb.delsol
 
Posts: 2
Joined: Tue Jul 09, 2013 4:02 pm

Previous

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 16 guests