Home Download Buy Blog Forum Support

[SOLVED] New version fails to start

[SOLVED] New version fails to start

Postby stevenmnance on Thu Nov 03, 2011 12:32 am

Just updated to the new beta version 2139 and it fails to start outputting:

Code: Select all
steven@lolwut:~/.sublime_text$ ./sublime_text

(sublime_text:3448): GLib-CRITICAL **: the GVariant format string `(u)' has a type of `(u)' but the given value has a type of `(s)'

(sublime_text:3448): GLib-CRITICAL **: g_variant_get: assertion `valid_format_string (format_string, TRUE, value)' failed


2126 Still works fine.

Anyone else having this problem?
Running on 64bit xubuntu 11.10 if that helps.
Last edited by stevenmnance on Fri Nov 04, 2011 11:20 am, edited 1 time in total.
stevenmnance
 
Posts: 2
Joined: Thu Nov 03, 2011 12:27 am

Re: New version fails to start

Postby defrex on Thu Nov 03, 2011 3:47 pm

I'm having this problem as well.

Ubuntu 11.04 64bit
defrex
 
Posts: 2
Joined: Thu Nov 03, 2011 3:45 pm

Re: New version fails to start

Postby defrex on Thu Nov 03, 2011 3:49 pm

Where can I download old versions? I can't find them, and I need my editor back asap.
defrex
 
Posts: 2
Joined: Thu Nov 03, 2011 3:45 pm

Re: New version fails to start

Postby jbjornson on Thu Nov 03, 2011 4:16 pm

defrex wrote:Where can I download old versions? I can't find them, and I need my editor back asap.


Copy the link for the most recent version, change the version number in the URL to the desired one, then open that edited URL.

For example, the latest stable build is 2139 and the last build was 2126. For the windows portable version, take the current URL and change it to point to the previous version.

So this:
http://c758482.r82.cf2.rackcdn.com/Subl ... 202139.zip

... becomes this:
http://c758482.r82.cf2.rackcdn.com/Subl ... 202126.zip

Hope that helps.
jbjornson
 
Posts: 344
Joined: Tue Oct 27, 2009 4:25 pm
Location: Zurich, Switzerland

Re: New version fails to start

Postby jps on Thu Nov 03, 2011 10:21 pm

I believe this issue is triggered if 2126 is still running, and then 2139 is started. For everyone who has seen this, please verify that there are no sublime_text processes hanging around when starting 2139.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: New version fails to start

Postby stevenmnance on Fri Nov 04, 2011 11:20 am

That seems to be it. Thanks! Starting w/o errors now.
stevenmnance
 
Posts: 2
Joined: Thu Nov 03, 2011 12:27 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], rothgar, Yahoo [Bot] and 40 guests