Home Download Buy Blog Forum Support

[SOLVED] Unable to run package setup

[SOLVED] Unable to run package setup

Postby rcrisman on Fri Nov 04, 2011 4:12 am

SB2 was running fine tell today, I am running Arch Linux...this is what I get when I try to start SB2 2138 & 2139

Unable to run package setup:

Traceback (most recent call last):
File "./PackageSetup.py", line 155, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 148, in upgradePackage
os.path.join(backupdir, base), inhibitOverwrite)
File "./PackageSetup.py", line 64, in upgradeArchive
fname = os.path.join(pkgdir, f)
File ".\posixpath.py", line 70, in join
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 49: ordinal not in range(128)
Last edited by rcrisman on Sun Nov 06, 2011 3:40 am, edited 1 time in total.
rcrisman
 
Posts: 4
Joined: Thu Nov 03, 2011 11:51 pm

Re: Unable to run package setup

Postby wbond on Sun Nov 06, 2011 3:29 am

So PackageSetup.py comes bundled with Sublime Text and provides basic package handling, primarily aimed at upgrading the packages that ship with Sublime. It does also automatically install .sublime-package files that are placed in the Installed Packages directory.

From the stack trace you posted, there is either a .sublime-package file in your Installed Packages directory, or the Pristine Packages folder that is a sibling to the sublime_text binary, that contains a non-ascii file name.

I've actually seen a number of errors related to PackageSetup.py preventing ST2 from starting. I've been meaning to see if I can work up a patch to send Jon that will help.
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am

Re: Unable to run package setup

Postby rcrisman on Sun Nov 06, 2011 3:39 am

Thanks Will that was a big help.
rcrisman
 
Posts: 4
Joined: Thu Nov 03, 2011 11:51 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 20 guests