Home Download Buy Blog Forum Support

Find in folder always reports 0 matches

Find in folder always reports 0 matches

Postby saxxi on Sun Nov 20, 2011 1:15 am

Hi,
I'm using Sublime-Text editor and it's been a while since I can't search anything.

Please note: I still can use command-line Ack for eg. "ack html"

Thanks,
Adit

STEPS
1. right-click on folder
2. click "Find in Folder..."
3. write anything in "Find What"
4. always get "0 matches" as result

MY CONFIGS
- Sublime-Text 2, build 2131
- Ubuntu 11.10 (32bit)
- ack v1.94
saxxi
 
Posts: 3
Joined: Sun Nov 20, 2011 1:02 am

Re: [BUG] Find in folder always reports 0 matches

Postby jps on Mon Nov 21, 2011 12:59 am

Check that you don't have options such as Whole Word turned on.

Also check the number of files it's searching through (i.e., check it doesn't say Searching 0 files for ...), in case all the files in the directory have been excluded.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Find in folder always reports 0 matches

Postby saxxi on Fri Nov 25, 2011 12:46 am

(sorry for late reply)

I checked, really nothing special, also tried different terms and tweaking search settings.

Also another thing is strange: some of my projects are huge but it doesn't even take a millisec
to determine he found 0 results; looks like he doesn't "try" - or not find ack?

Other than this, how can I try a clean install of sublime? (sometime back this feature was working)

Cheers,
Adit
saxxi
 
Posts: 3
Joined: Sun Nov 20, 2011 1:02 am

Re: Find in folder always reports 0 matches

Postby senzo on Fri Nov 25, 2011 11:04 am

Here you find a description of how to revert sublime text to a clean install. Don't delete your data folder, just move it somewhere.

http://www.sublimetext.com/docs/2/revert.html
senzo
 
Posts: 106
Joined: Tue May 24, 2011 9:17 am

Re: Find in folder always reports 0 matches

Postby jps on Fri Nov 25, 2011 1:49 pm

How many files is it searching through (listed at the top of the find results)?
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

[resolved] Re: Find in folder always reports 0 matches

Postby saxxi on Sat Nov 26, 2011 12:57 am

@senzo, moving sublime prefs folder worked fine, I'll put my prefs back one by one to see if still works
Thanks jps also! :)

Adit

ps. btw it was reporting -for any different search, in different search settings- :

Searching 0 files for "html" (case sensitive)

0 matches
saxxi
 
Posts: 3
Joined: Sun Nov 20, 2011 1:02 am

Re: Find in folder always reports 0 matches

Postby jps on Sat Nov 26, 2011 1:23 am

The issue will then be that one of your folder_exclude_patterns, file_exclude_patterns or binary_file_patterns global settings was excluding all the files.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 18 guests