Home Download Buy Blog Forum Support

Can't import multiprocessing in plugin

Can't import multiprocessing in plugin

Postby johtso on Wed Nov 23, 2011 1:43 am

When I try to import multiprocessing I get this Traceback:

Code: Select all
Traceback (most recent call last):
  File ".\sublime_plugin.py", line 57, in reload_plugin
  File ".\plugin.py", line 5, in <module>
    from multiprocessing import Process, Queue
  File "<string>", line 27, in load_module
  File ".\multiprocessing\__init__.py", line 83, in <module>
ImportError: No module named _multiprocessing


Does anyone know what's going on?
johtso
 
Posts: 8
Joined: Thu Sep 22, 2011 11:06 pm

Re: Can't import multiprocessing in plugin

Postby wbond on Wed Nov 23, 2011 2:53 pm

This indicates the multiprocessing module in not bundled with the version of Python Sublime uses for its API.
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 36 guests