Home Download Buy Blog Forum Support

sublime doesn't work after package upgrade

sublime doesn't work after package upgrade

Postby krzyzak on Fri Dec 09, 2011 1:04 pm

Hi,
I'm running Sublime Text 2 Build 2139.
Recently, I've run upgrade all packages, and now I can't run my editor.
I've got following traceback:
Code: Select all
Unable to run package setup:

Traceback (most recent call last):
  File "./PackageSetup.py", line 155, in upgrade
    upgradePackage(pkg, pristinedir, datadir, backupdir)
  File "./PackageSetup.py", line 148, in upgradePackage
    os.path.join(backupdir, base), inhibitOverwrite)
  File "./PackageSetup.py", line 64, in upgradeArchive
    fname = os.path.join(pkgdir, f)
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/posixpath.py", line 70, in join
    path += '/' + b
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 49: ordinal not in range(128)


Any help will be greatly appreciated ;)
krzyzak
 
Posts: 1
Joined: Fri Dec 09, 2011 1:00 pm

Re: sublime doesn't work after package upgrade

Postby wbond on Fri Dec 09, 2011 3:34 pm

Look in your Installed Packages directory to see if there is a zip file of sublime-package file. It appears that a package contains a file with a non-ascii filename. Delete it and you should be able to start Sublime again. On OSX Installed Packages is in ~/Library/Application Support/Sublime Text 2/, on Windows in C:\Users\{username}\AppData\Roaming\Sublime Text 2\ and on Linux in ~/.config/sublime-text-2/.
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 33 guests