Home Download Buy Blog Forum Support

Bug 2161: fontStyle doesn't work anymore ?

Bug 2161: fontStyle doesn't work anymore ?

Postby bizoo on Mon Jan 09, 2012 8:04 am

Upgrading for 2152 to 2161, it look like the fontStyle from tmTheme doesn't work anymore.
There's no more italic text in my Python source using Monokai theme.

Is there something wrong on my system or is this a regression in last build ?

startup, version: 2161 windows x64 channel: dev
bizoo
 
Posts: 886
Joined: Wed Dec 08, 2010 6:53 am
Location: Switzerland

Re: Bug 2161: fontStyle doesn't work anymore ?

Postby jps on Mon Jan 09, 2012 8:40 am

It's still working, although restrictions have been placed on which fonts it'll work with - it'll only be used if the font and its italic/bold versions are the same width.

What font and font_options are you using?
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug 2161: fontStyle doesn't work anymore ?

Postby bizoo on Mon Jan 09, 2012 9:02 am

You're right, this is my config:
Code: Select all
   "font_face": "Meslo LG M",
   "font_size": 11,

Meslo come from https://github.com/andreberg/Meslo-Font

It works with font_size = 10 or 12, but not for 11

Edit: Any chance that it work again with 11 ?
bizoo
 
Posts: 886
Joined: Wed Dec 08, 2010 6:53 am
Location: Switzerland

Re: Bug 2161: fontStyle doesn't work anymore ?

Postby bizoo on Thu Jan 12, 2012 7:56 am

Sorry to bother you Jon, but is there any chance that my current config work again in next build or do I have to find a new font ?
It took me a while to find a font/size that I really like.
bizoo
 
Posts: 886
Joined: Wed Dec 08, 2010 6:53 am
Location: Switzerland


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 28 guests