Home Download Buy Blog Forum Support

Strange issue with tabbing/enter and Zen Coding package

Strange issue with tabbing/enter and Zen Coding package

Postby hxcobd on Mon Jan 09, 2012 5:32 pm

I'm on build 2139, using the Zen Coding package, installed via Package Control.

I don't remember Zen Coding doing this before, in previous versions:

When I use Zen Coding shorthand to write html (such as "div#lolFun"), and then hit tab, it is expanded properly. The cursor is placed between the DIV tags, as expected. However, from here, the enter key does not do anything; I'm unable to do anything from this position except type in text between the tags, or hit tab to exit the cursor from the DIV. This is fine for empty DIVs, but when I want to immediately place the DIV's interior content on a new line (i.e. most of the time), this is irritating. I'd like for the enter key to work as expected when the cursor is placed between the DIV tags after expanding a Zen bit.

Anyone know why it's doing this?

*edit - It also appears that tab autocomplete isn't working at all on anything other than direct DIV elements (i.e. "div#lolFun>ul>li*8" does not work at all).
hxcobd
 
Posts: 7
Joined: Wed Jun 29, 2011 4:29 pm

Re: Strange issue with tabbing/enter and Zen Coding package

Postby bobspryn on Mon Jan 09, 2012 11:32 pm

There were some other threads about this. Its a bug that can be worked around by appending a > to the end of your lines before expanding. Hopefully its fixed soon.
bobspryn
 
Posts: 20
Joined: Fri Apr 08, 2011 10:00 pm

Re: Strange issue with tabbing/enter and Zen Coding package

Postby hxcobd on Mon Jan 09, 2012 11:39 pm

Ahh, I did see those threads, but assumed it was an unrelated issue. Thanks for the heads up.
hxcobd
 
Posts: 7
Joined: Wed Jun 29, 2011 4:29 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 17 guests