Home Download Buy Blog Forum Support

'Unable to run package setup' after upgrading to 2165

'Unable to run package setup' after upgrading to 2165

Postby brunoqc on Thu Jan 12, 2012 2:29 pm

I got this problem on the second Sublime run after I delete my "q:\AppData\Sublime Text 2" (Sublime runs fine when "q:\AppData\Sublime Text 2" doesn't exists).

I'm on Windows.

Code: Select all
Unable to run package setup:

Traceback (most recent call last):
  File ".\PackageSetup.py", line 165, in upgrade
    upgradePackage(pkg, pristinedir, datadir, backupdir)
  File ".\PackageSetup.py", line 158, in upgradePackage
    os.path.join(backupdir, base), inhibitOverwrite)
  File ".\PackageSetup.py", line 113, in upgradeArchive
    shutil.copy(src, dst)
  File ".\shutil.py", line 88, in copy
  File ".\shutil.py", line 53, in copyfile
IOError: [Errno 13] Permission denied: u'q:\\AppData\\Sublime Text 2\\Pristine Packages\\ActionScript.sublime-package'


If I delete "ActionScript.sublime-package" the error will say it has a problem with "AppleScript.sublime-package".
brunoqc
 
Posts: 1
Joined: Thu Jan 12, 2012 2:26 pm

Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Yahoo [Bot] and 31 guests