Home Download Buy Blog Forum Support

Auto Completion Issue

Auto Completion Issue

Postby seriouslysean on Sat Jan 14, 2012 7:27 pm

Since the update to the newest version, for the life of me I can't seem to get the auto completion functionality to leave me alone. I've made all of the changes to the user preferences file disabling everything, but tab by itself is still auto completing all of the time. Could anyone help me sort out this issue?

Here is my user file settings if it's any help.
Code: Select all
{
   "auto_complete": false,
   "auto_complete_commit_on_tab": false,
   "auto_complete_delay": 50,
   "auto_complete_selector": "source - comment",
   "auto_complete_size_limit": 4194304,
   "auto_complete_triggers":
   [
      {
         "characters": "<",
         "selector": "text.html"
      }
   ],
   "auto_complete_with_fields": false,
   "auto_indent": true,
   "auto_match_enabled": true,
   "caret_style": "smooth",
   "color_scheme": "Packages/Color Scheme - Default/Pastels on Dark.tmTheme",
   "default_encoding": "UTF-8",
   "default_line_ending": "system",
   "detect_indentation": true,
   "dictionary": "Packages/Language - English/en_US.dic",
   "draw_centered": false,
   "draw_indent_guides": true,
   "draw_minimap_border": false,
   "draw_white_space": "selection",
   "ensure_newline_at_eof_on_save": false,
   "fade_fold_buttons": true,
   "fallback_encoding": "Western (Windows 1252)",
   "find_selected_text": true,
   "fold_buttons": true,
   "font_face": "Inconsolata",
   "font_options":
   [
   ],
   "font_size": 12,
   "gutter": true,
   "highlight_line": false,
   "indent_guide_options":
   [
      "draw_normal"
   ],
   "indent_subsequent_lines": true,
   "line_numbers": true,
   "line_padding_bottom": 0,
   "line_padding_top": 0,
   "match_brackets": true,
   "match_brackets_angle": false,
   "match_brackets_braces": true,
   "match_brackets_content": true,
   "match_brackets_square": true,
   "match_tags": true,
   "move_to_limit_on_up_down": false,
   "rulers":
   [
   ],
   "save_on_focus_lost": false,
   "scroll_past_end": true,
   "shift_tab_unindent": false,
   "spell_check": false,
   "tab_completion": false,
   "tab_size": 2,
   "translate_tabs_to_spaces": true,
   "trim_automatic_white_space": true,
   "trim_trailing_white_space_on_save": false,
   "use_tab_stops": true,
   "word_separators": "./\\()\"'-:,.;<>~!@#$%^&*|+=[]{}`~?",
   "word_wrap": true,
   "wrap_width": 0
}

seriouslysean
 
Posts: 2
Joined: Sat Jan 14, 2012 7:25 pm

Re: Auto Completion Issue

Postby C0D312 on Sat Jan 14, 2012 8:02 pm

Since you have tab completion and autocomplete disabled, my guess is you don't like snippets? You can delete all your snippets if you'd like, but could you give an example of the problem?
C0D312
 
Posts: 1063
Joined: Sun Jul 10, 2011 3:23 am

Re: Auto Completion Issue

Postby seriouslysean on Sat Jan 14, 2012 8:19 pm

Ok, so here's an example of what I ran in to today:

I was working with some javascript and when I type in gallery_atts followed by the colon and then press tab, it auto completed to gallery_attskeys: "value", and kept doing that over and over again. I couldn't get a normal tab to insert unless I pressed ctrl+tab.

Thanks for any help!

Code: Select all
data: {
              action:         'tyr',
              page_num:       pageNum,
              gallery_atts:   galleryAtts,
              form_action:    'generate_gallery_page'
              },
seriouslysean
 
Posts: 2
Joined: Sat Jan 14, 2012 7:25 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Soulsbane, Topic and 27 guests