Home Download Buy Blog Forum Support

Won't let me type in braces

Won't let me type in braces

Postby kstenerud on Sun Jan 15, 2012 3:56 pm

I was writing some Objective-J code like so:

Code: Select all
var something = CPArray


Then I tried to type the "]" character to add the Objective-J brace, but it wouldn't let me type it.

So I went to the beginning of "CPArray" and typed in the beginning square brace:

Code: Select all
var something = [CPArray


Then I went back to the end and tried to type the end brace, but it STILL wouldn't let me. It seems the only way ST lets you enter braces properly is if you type the beginning brace BEFORE you type anything else at all. You can't decorate existing code with braces like you could with a normal editor or with Xcode.

Even if it didn't handle braces properly, an editor should never outright refuse to put in a character you typed.
kstenerud
 
Posts: 1
Joined: Sun Jan 15, 2012 3:47 pm

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 21 guests