Home Download Buy Blog Forum Support

Editing associated filetypes in Plist.info won't work

Editing associated filetypes in Plist.info won't work

Postby wrndl on Wed Jan 25, 2012 7:50 pm

Hello,

I edit a lot of .sass, .scss, html.twig files. And since that, I wanted to associate these to Sublime Text 2.
Therefor I opened Info.plist in it's Package Contents and edited it like that:

Code: Select all
      
<dict>
   <key>CFBundleTypeRole</key>
   <string>Editor</string>
   <key>CFBundleTypeName</key>
   <string>SASS</string>
   <key>CFBundleTypeExtensions</key>
   <array>
      <string>sass</string>
   </array>
   <key>CFBundleTypeIconFile</key>
   <string>CSS</string>
</dict>


and

Code: Select all
<dict>
   <key>CFBundleTypeRole</key>
   <string>Editor</string>
   <key>CFBundleTypeName</key>
   <string>HTML</string>
   <key>CFBundleTypeExtensions</key>
   <array>
      <string>html</string>
      <string>html.twig</string>
      <string>email.md.twig</string>
      <string>htm</string>
      <string>shtml</string>
      <string>xhtml</string>
      <string>phtml</string>
      <string>inc</string>
      <string>tpl</string>
      <string>tmpl</string>
      <string>tpl</string>
      <string>ctp</string>
   </array>
   <key>CFBundleTypeIconFile</key>
   <string>HTML</string>
</dict>


(FYI, I followed: http://superuser.com/questions/178316/how-to-set-an-icon-for-a-file-type-on-mac)

But after closing and moving the whole App to the ~/Desktop launching it and moving it back to ~/Applications, launching it again, nothing happens. I also tried rebooting OS X.

Does someone have an idea what I'm doing wrong here?

Regards,
Alex

Update: I'm also sure, that I don't have already set a custom icon to these files. I created some new test.sass etc. files on my desktop to check for that.
wrndl
 
Posts: 2
Joined: Wed Jan 25, 2012 7:39 pm

Re: Editing associated filetypes in Plist.info won't work

Postby wrndl on Sat Jan 28, 2012 2:43 pm

Solved: http://superuser.com/questions/382760/s ... -wont-work

I'm not sure, why it's necessary (at least in my case) to put the SASS block on top, but it seams to work.
wrndl
 
Posts: 2
Joined: Wed Jan 25, 2012 7:39 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], rozling and 15 guests