Home Download Buy Blog Forum Support

Can't install any packages through package control

Can't install any packages through package control

Postby thepuzzlemaster on Mon Jan 30, 2012 12:53 pm

I'm getting the following error on startup with any package I try to install:

Unable to run package setup:

Traceback (most recent call last):
File "./PackageSetup.py", line 165, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 158, in upgradePackage
os.path.join(backupdir, base), inhibitOverwrite)
File "./PackageSetup.py", line 32, in upgradeArchive
newar = zipfile.ZipFile(src)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 698, in __init__
self._GetContents()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 718, in _GetContents
self._RealGetContents()
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 728, in _RealGetContents
endrec = _EndRecData(fp)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 189, in _EndRecData
fpin.seek(-sizeEndCentDir, 2)
IOError: [Errno 22] Invalid argument


I tried deleting my entire data folder. No luck. Using build 2165. I can install packages manually, no problem. When I install a package through package control, the sublime-pacage files just sit in my installed packages directory. If I delete them, it will start ok, but it never installs the packages. Not sure what to try next.

Any help would be appreciated.

Thanks.
thepuzzlemaster
 
Posts: 3
Joined: Mon Jan 30, 2012 12:49 pm

Re: Can't install any packages through package control

Postby thepuzzlemaster on Thu Feb 02, 2012 7:16 am

I've read through the post listed below, but I'm in a mac environment, and I'm not sure how this would translate into osx. Anyone have any insight into this? (I'm a pc person, but use a mac for work).

https://github.com/wbond/sublime_packag ... /issues/67
thepuzzlemaster
 
Posts: 3
Joined: Mon Jan 30, 2012 12:49 pm

Re: Can't install any packages through package control

Postby thepuzzlemaster on Mon Feb 06, 2012 4:38 pm

Well it appears as though the issue was related to me being behind a proxy server. I was in South Africa for work when I was having the problems and the office there uses a proxy server. I'm now back in Seattle, and just installed a package without any problems, so things appear to be working correctly.

Hooray!
thepuzzlemaster
 
Posts: 3
Joined: Mon Jan 30, 2012 12:49 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Orlmente, Yahoo [Bot] and 32 guests