Home Download Buy Blog Forum Support

[BUG] Syntax not loading with extension

[BUG] Syntax not loading with extension

Postby Gravy on Thu Feb 16, 2012 1:53 pm

When I open a file like "whatever.php" the code loads with the PHP syntax with no problems.

However, when I open a file with nothing before the dot ".php", it does not load the PHP syntax and I can not find any way around this other than manually loading the syntax each and every time. This is tiring...

Can this bug be fixed? And is there any way around it until it is, it's one of the only 2 things starting to turn me off Sublime Text.
Gravy
 
Posts: 14
Joined: Wed Feb 15, 2012 6:55 am

Re: [BUG] Syntax not loading with extension

Postby Gravy on Fri Feb 17, 2012 11:20 pm

BUMP!
Gravy
 
Posts: 14
Joined: Wed Feb 15, 2012 6:55 am

Re: [BUG] Syntax not loading with extension

Postby phillip.koebbe on Sat Feb 18, 2012 12:41 am

Gravy wrote:is there any way around it


You could try DetectSyntax. It should work. It's available via Package Control.
-- Phillip

Code: Select all
while self.living? do
    mistake = Mistake.new
    self.learn_from!(mistake) unless mistake.fatal?
end
phillip.koebbe
 
Posts: 208
Joined: Tue Dec 20, 2011 4:58 pm

Re: [BUG] Syntax not loading with extension

Postby Gravy on Sat Feb 18, 2012 3:00 am

phillip.koebbe wrote:
Gravy wrote:is there any way around it


You could try DetectSyntax. It should work. It's available via Package Control.


Thanks, that was a great idea and work around until they fix it.
Gravy
 
Posts: 14
Joined: Wed Feb 15, 2012 6:55 am

Re: [BUG] Syntax not loading with extension

Postby Gravy on Wed Dec 18, 2013 4:21 am

It appears:

DetectSyntax has been renamed ApplySyntax for SublimeText3.
Gravy
 
Posts: 14
Joined: Wed Feb 15, 2012 6:55 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 37 guests