Home Download Buy Blog Forum Support

Very strange bug in several Linux distributions with nVidia

Very strange bug in several Linux distributions with nVidia

Postby damnwidget on Thu Feb 23, 2012 2:49 pm

Greetings.

I discovered a very weird bug with SublimeText 2 x86_64 Linux build. I dont know how to reproduce exactly but some times X server process go to 100% of his CPU core and then all the X system get frozen except the mouse cursor until you kill the X server. This happens on KDE and GNOME as well.

Some times, the system just frozen at all, you can't open a SSH connection to the machine or do login with any virtual terminal, you can not perform any system call but if you have a top up and running all seems normal, no proccess eating CPU or RAM.

Those problems only happend to me using SublimeText 2 I did check my MB (EVGA SLI Classified) and GPU (nVidia GTX 480) and it's ok.

I'll investigate more deeply to find a solution but this problem really sucks because I can not use my loved editor on Linux which is my main Operating System (thanks god I have a MacBook Pro so I can use it on Mac OS X without problems).

I did replicate this problem on Gentoo, ArchLinux and Sabayon so it seems is not related to Kernel, or ny set of packages or drivers.

¿Maybe this is caused because some plug-in? I used my Sublime Text 2 before without any problems in the same system with the same hardware configuration.
damnwidget
 
Posts: 12
Joined: Thu Feb 23, 2012 2:35 pm

Re: Very strange bug in several Linux distributions with nVidia

Postby damnwidget on Sun Mar 11, 2012 5:41 pm

I found what's wrong and was producing ths problem.

The plugin BracketHighlither was crashing the system, I just uninstall it and no crashes for more than ten days.

Greetings.
damnwidget
 
Posts: 12
Joined: Thu Feb 23, 2012 2:35 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 19 guests