Home Download Buy Blog Forum Support

Problems in Package Control with ST 2181

Problems in Package Control with ST 2181

Postby syndrael on Tue Feb 28, 2012 5:04 pm

Hello,
I've upgraded ST2 - 64bits in 2181 and i can't install new package with Package Control.
In the bottom bar there's Loading repositoires [ = ] and nothing else after 30 seconds.
May be there's a log file containing errors.
Could you help me ?
Best regards
S.
syndrael
 
Posts: 6
Joined: Tue Dec 27, 2011 9:27 am

Re: Problems in Package Control with ST 2181

Postby s0ber on Sat Mar 17, 2012 1:23 pm

Got the same problem. Is there any way to fix it?
s0ber
 
Posts: 2
Joined: Sat Mar 17, 2012 1:22 pm

Re: Problems in Package Control with ST 2181

Postby s0ber on Sat Mar 17, 2012 2:15 pm

Just have solved it using this settings in Package Control.sublime-settings:

Code: Select all
{
    "auto_upgrade_last_run": 1331660912,
    "repositories": [
        "https://bitbucket.org/sublimator/sublime-2-zencoding"
    ],
    "repository_channels": [
        "http://sublime.wbond.net/repositories.json"
    ]
}
s0ber
 
Posts: 2
Joined: Sat Mar 17, 2012 1:22 pm

Re: Problems in Package Control with ST 2181

Postby wbond on Thu Mar 29, 2012 3:32 pm

Package Control switched to using https to prevent man-in-the-middle attacks where arbitrary python code could be run on your machine. Some users were reporting issues connecting to the server via SSL. I believe it may have been due to old server software. Just today I finished the transition to a new server, which should hopefully fix this for a lot of users.

Please let me know if https://sublime.wbond.net/repositories.json works in repository_channels now.
wbond
 
Posts: 527
Joined: Mon Feb 28, 2011 5:33 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], kozie, Yahoo [Bot] and 24 guests