Home Download Buy Blog Forum Support

[BUG] Selecting text doesn't update the X selection buffer

[BUG] Selecting text doesn't update the X selection buffer

Postby johanboss on Tue Mar 06, 2012 6:18 pm

There is a bug in the way the X selection is updated on Linux. And for a native Linux user this is a very frustrating bug, for users not aware of X two clipboard functionality it may be hard to comprehend, but believe me when I say that this is most annoying to any Linux user.

So please take a look at this asap and fix it in the next release :-) (Fixing this will make S2 near perfect to my needs)

I should also mention that the X selection is sometimes updated, but not fully, e.g. it may contain a single word out of several, one line out of several lines etc. So it works a bit but not fully.

Info on bug (copied from userecho):
- (Main issue) Selecting text doesn't update the X selection buffer.
- Text should be pasted from the selection buffer with either middle-click or shift-ins. In Sublime, shift-ins pastes from the clipboard (i.e. duplicates ctrl-V).
- Deselecting text (clicking away or changing file) should not empty the selection buffer. The buffer should continue to hold the most recently selected text.

Steps to reproduce (copied from userecho):
1) Select some text in a terminal
2) Open sublime and paste the text with middle click on the location you want the text (works correctly)
3) Type some new text, select it.
4) Go to a terminal, notice that your selection from before is no longer selected (selecting in sublime correctly deselects it, this is standard behavior in linux)
5) Select something new
6) Go back to sublime, notice that your selection has remained (erroneously).
7) Paste using middle click to find that your selection from the terminal pasted.

There is also a ticket here about this issue, where several other users have also noticed this bug;
http://sublimetext.userecho.com/topic/4 ... tion-down/
johanboss
 
Posts: 1
Joined: Tue Mar 06, 2012 6:11 pm

Re: [BUG] Selecting text doesn't update the X selection buffer

Postby jackocnr on Mon Mar 26, 2012 7:37 pm

I'm also having this problem and would love to see it fixed. To sum up my problem: if I select some text in ST2, then middle click to paste it somewhere else, it's missing the first few characters.

Thanks!
jackocnr
 
Posts: 5
Joined: Wed Mar 07, 2012 9:35 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 12 guests