Home Download Buy Blog Forum Support

Bug: jump-to-end of line in word wrap mode

Bug: jump-to-end of line in word wrap mode

Postby cwolves on Tue Apr 03, 2012 7:26 pm

When word wrap mode is on, jump to end of line goes to the end of the on-screen line, not the actual line, e.g:

this is some long text <-- cursor would go here
that gets wrapped <-- cursor should go here
cwolves
 
Posts: 12
Joined: Thu Jan 12, 2012 9:01 pm

Re: Bug: jump-to-end of line in word wrap mode

Postby S0und on Fri Apr 06, 2012 12:17 pm

exp.:

v2192

Image
S0und
 
Posts: 70
Joined: Wed Oct 28, 2009 4:12 pm

Re: Bug: jump-to-end of line in word wrap mode

Postby jps on Sat Apr 07, 2012 3:25 am

This is working as designed.

You can change the key binding if you'd like this behavior, changing the "eol" argument to move_to to "hardeol"
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug: jump-to-end of line in word wrap mode

Postby cwolves on Wed Apr 18, 2012 5:58 pm

Okay, I added the one and it works. Can't figure out the others though:

Code: Select all
   , { "keys": ["super+right"], "command": "move_to", "args": {"to": "hardeol"} }
   , { "keys": ["super+shift+right"], "command": "expand_selection", "args": {"to": "hardeol"} }


I need 'select-to-end-of-line' (trying to get above). Also, is there an intermediate command between 'bol' and 'hardbol'? I want the bol to work the same (first non-whitespace, then hard)

Also, I vote that the behavior is incorrect and should be flipped by default. EOL behavior should not be different depending on whether or not word-wrap is on and what the wrap setting is set to. Multiple cursors suddenly lose half of their value with word-wrap on because EOL goes to different positions with different cursors and I don't see any way to align them to "hard eol" without flipping this option.
cwolves
 
Posts: 12
Joined: Thu Jan 12, 2012 9:01 pm

Re: Bug: jump-to-end of line in word wrap mode

Postby cutcopypaste on Fri Jan 25, 2013 9:56 pm

I agree this seems incorrect to me.

And also need an equivalent for the bol that ignores the whitespace
I set mine to ctrl+alt+home and Ctrl+alt+shift+home
cutcopypaste
 
Posts: 41
Joined: Tue Feb 21, 2012 9:43 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 18 guests