Home Download Buy Blog Forum Support

Problem with Polish and probably others keys mapping

Problem with Polish and probably others keys mapping

Postby artee on Tue Oct 13, 2009 7:08 pm

Hi SB maniacs

In some languages right Alt key is used to enter some local specify characters (like Alt+O to enter 'ó' character in Polish).
Sublime doesn't recognise right and left Alt keys.
So, instead of 'ó' character in example above "Open file" option is called when user press right Alt key with 'o'.
The same problems is in another languages like German or Russian.
Is it a bug or rather configuration problem?

Regards,
Artur
artee
 
Posts: 32
Joined: Sat May 30, 2009 10:33 pm

Re: Problem with Polish and probably others keys mapping

Postby jps on Tue Oct 13, 2009 8:41 pm

Sublime Text currently consumes right-alt key presses and handles it like a left-alt key press. I'll change this for the next beta so that it's ignored instead, which will allow ó etc to be typed.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Problem with Polish and probably others keys mapping

Postby vim on Wed Oct 14, 2009 5:59 am

could you have it configurable? because on other keyboards one doesn't expect the right alt to be ignored
vim
 
Posts: 298
Joined: Tue May 27, 2008 6:51 pm

Re: Problem with Polish and probably others keys mapping

Postby jps on Wed Oct 14, 2009 8:22 am

Artee, which platform are you seeing this behaviour on?

On Vista, when switching to the Polish keyboard layout, I'm able to type right-alt+m and get a '§' inserted, rather than have the minimap toggled, which is what happens when I use my usual keyboard layout.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Problem with Polish and probably others keys mapping

Postby artee on Wed Oct 14, 2009 8:50 am

jps wrote:Artee, which platform are you seeing this behaviour on?
On Vista, when switching to the Polish keyboard layout, I'm able to type right-alt+m and get a '§' inserted, rather than have the minimap toggled, which is what happens when I use my usual keyboard layout.


I've tested it on Windows XP Pro [PL and EN] and Windows Vista Bussines [EN].
In Poland we use Polish (Programmers) keyboard layout. I have no idea what kind of keyboard layouts are used in other countries.
Maybe 'Default input language' in 'Text Services and Input Languages' window is taken into consideration?
In my layout right alt + m causes nothing.

To test polish characters, run the Notepad and try:
Right Alt + L => 'ł' character
Right Alt + Shift + L => 'Ł' character
Right Alt + S => 'ś' character
Right Alt + Shift + S => 'Ś' character
Right Alt + S => 'ą' character
Right Alt + Shift + S => 'Ą' character
and so on...
The same behaviour is seen in other editors like Wordpad or Scite.
I can provide some print screens if they can help in your investigations :)

Thanks,
Artur
artee
 
Posts: 32
Joined: Sat May 30, 2009 10:33 pm

Re: Problem with Polish and probably others keys mapping

Postby artee on Wed Oct 14, 2009 8:52 am

It should be:
Right Alt + A => 'ą' character
Right Alt + Shift + A => 'Ą' character
:)
artee
 
Posts: 32
Joined: Sat May 30, 2009 10:33 pm

Re: Problem with Polish and probably others keys mapping

Postby jps on Wed Oct 14, 2009 11:34 am

I was testing with the "Polish (214)" keyboard layout before, I've now changed to "Polish (Programmers)" - still on Vista.

The Right Alt keys work as you describe for me, in both notepad and Sublime Text.

With the programmers layout, Left Alt+M toggles the minimap, and Right Alt+M does nothing. Does the minimap toggle for you when you press Right Alt+M?
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Problem with Polish and probably others keys mapping

Postby artee on Wed Oct 14, 2009 2:27 pm

I've installed the newest beta 20091010 and it looks thas it works better then previous beta (near 1.2.2).
But the problem still exists for Right Alt + O and Right Alt + Shift + O.
Instead of 'ó' for Right Alt + O, "open in current tab" option is called.
Instead of 'Ó' for Right Alt + Shift + O, "select file" option is called (Ctrl+Shift+O should do that).

Thanks,
Artur
artee
 
Posts: 32
Joined: Sat May 30, 2009 10:33 pm

Re: Problem with Polish and probably others keys mapping

Postby jps on Wed Oct 14, 2009 8:38 pm

That would seem to be this issue: http://blogs.msdn.com/oldnewthing/archi ... 01121.aspx

Perhaps the best thing to do is to remove the ctrl+alt key bindings locally, although there's no way to do that via editing only User/Default.sublime-keymap, unfortunately.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Problem with Polish and probably others keys mapping

Postby artee on Wed Oct 21, 2009 9:18 pm

jps wrote:That would seem to be this issue: http://blogs.msdn.com/oldnewthing/archi ... 01121.aspx
Perhaps the best thing to do is to remove the ctrl+alt key bindings locally, although there's no way to do that via editing only User/Default.sublime-keymap, unfortunately.

In the most recent sublime beta only two problems with above still exist: RAlt + O and Shift + RAlt + O. Instead of 'ó' or 'Ó' respectively, Sublime commands are called. In any other editor for given platform above shortcuts works fine.

Regards,
Artur
artee
 
Posts: 32
Joined: Sat May 30, 2009 10:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 27 guests