Home Download Buy Blog Forum Support

Bold & italic not working with Droid Sans Mono

Bold & italic not working with Droid Sans Mono

Postby quodlibet on Mon Apr 16, 2012 9:17 pm

I have noticed that bold and italic styles are ignored for certain fonts. After reading various bits and pieces about how Sublime handles fonts, I am still confused. I would like to use Droid Sans Mono but when I switch to it, the bold and italic styles which worked fine with Consolas, Meslo, etc, are ignored. Any ideas?
quodlibet
 
Posts: 547
Joined: Sat Jun 18, 2011 5:53 pm

Re: Bold & italic not working with Droid Sans Mono

Postby pete340 on Mon Apr 16, 2012 10:41 pm

quodlibet wrote:I have noticed that bold and italic styles are ignored for certain fonts. After reading various bits and pieces about how Sublime handles fonts, I am still confused. I would like to use Droid Sans Mono but when I switch to it, the bold and italic styles which worked fine with Consolas, Meslo, etc, are ignored. Any ideas?


Does Droid Sans Mono have bold and italic typefaces?
pete340
 
Posts: 78
Joined: Mon Oct 10, 2011 9:45 pm

Re: Bold & italic not working with Droid Sans Mono

Postby quodlibet on Tue Apr 17, 2012 8:16 am

I thought I knew the answer to this question to be yes, but I'm less sure know. Droid Sans Mono comes in a single .ttf file but all applications except ST can output bold & italic. Does this mean that whatever Linux uses for font rendering does this on the fly?

Edit: Yes that seems to be the case. Droid Sans Mono does not provide bold and italic.
quodlibet
 
Posts: 547
Joined: Sat Jun 18, 2011 5:53 pm

Re: Bold & italic not working with Droid Sans Mono

Postby pete340 on Tue Apr 17, 2012 11:16 am

quodlibet wrote:I thought I knew the answer to this question to be yes, but I'm less sure know. Droid Sans Mono comes in a single .ttf file but all applications except ST can output bold & italic. Does this mean that whatever Linux uses for font rendering does this on the fly?

Edit: Yes that seems to be the case. Droid Sans Mono does not provide bold and italic.


It's possible to "convert" a plain typeface to a slanted one or to a thicker one, but to purists, neither is acceptable. Only a properly designed italic or bold typeface will do. <g>

That is, applications that output bold & italic from a font family that doesn't include them are faking it. The fake may look reasonable, but it doesn't reflect the esthetics of the underlying typeface. That may be acceptable for some uses, including, perhaps, displaying text in an editor.

Hmm, is there a hint of disapproval in what I've just said?
pete340
 
Posts: 78
Joined: Mon Oct 10, 2011 9:45 pm

Re: Bold & italic not working with Droid Sans Mono

Postby quodlibet on Tue Apr 17, 2012 12:26 pm

pete340 wrote:Hmm, is there a hint of disapproval in what I've just said?


Yes, there is :)

I actually understand a sufficient amount about typography to balk at faked weight and styles, so I wouldn't want to go down this road even if it was available. I just wasn't being attentive.

It's a typographic concern that led me to this trouble in the first place. I was looking for a monospace typeface with a Greek that works well for long texts. I do all my writing in text editors, Sublime most recently, and the Greek glyphs of most monospace faces seem to me to be derived from math symbols rather than written letters.

I've been switching between Consolas and Meslo but I have various niggles with both of these. Oh, well.

I rather like the Greek of Droid, so I'll stick to it; it may turn out that the absence of bold & italic is less of a deal breaker than I think it is.

Unless anyone has a monospace font with excellent Greek to suggest...
quodlibet
 
Posts: 547
Joined: Sat Jun 18, 2011 5:53 pm

Re: Bold & italic not working with Droid Sans Mono

Postby SeanWcom on Tue Apr 17, 2012 1:05 pm

quodlibet wrote:
pete340 wrote:I've been switching between Consolas and Meslo but I have various niggles with both of these. Oh, well.


Out of curiosity, is one of the problems you see with Meslo the left indentation (or tab stops)? I indent with two spaces as my tabs (no tabs allowed) and I find that the left side of my text does not line up with the guidelines that are shown at the proper two space indentation. Very strange.
Multiple selections... one of my favorite ST2 features. View some noob-friendly screen casts here.
SeanWcom
 
Posts: 101
Joined: Wed Aug 03, 2011 1:31 am
Location: Georgia

Re: Bold & italic not working with Droid Sans Mono

Postby quodlibet on Tue Apr 17, 2012 2:51 pm

SeanWcom wrote:Out of curiosity, is one of the problems you see with Meslo the left indentation (or tab stops)? I indent with two spaces as my tabs (no tabs allowed) and I find that the left side of my text does not line up with the guidelines that are shown at the proper two space indentation. Very strange.


My issue with Consolas and Meslo is that their Greek glyphs are too quirky or decorative, respectively. Nothing to do with sublime, I'm afraid.

On the other hand, your description seems to indicate that Sublime doesn't render Meslo properly. I had a look at Meslo indented by two spaces and I don't see any problems; but perhaps I don't understand what you are referring to. Can you provide a screenshot?
quodlibet
 
Posts: 547
Joined: Sat Jun 18, 2011 5:53 pm

Re: Bold & italic not working with Droid Sans Mono

Postby SeanWcom on Tue Apr 17, 2012 4:45 pm

Sure - I'll do one better. Here's a quick screencast. You may have to pause to read my text... Jing only allows a few minutes in the free client. :)

http://screencast.com/t/j2lLIt9us
Multiple selections... one of my favorite ST2 features. View some noob-friendly screen casts here.
SeanWcom
 
Posts: 101
Joined: Wed Aug 03, 2011 1:31 am
Location: Georgia

Re: Bold & italic not working with Droid Sans Mono

Postby quodlibet on Tue Apr 17, 2012 5:23 pm

I see what you mean, but I can't replicate the behavior on Ubuntu, ST build 2190.

Meslo LG M DZ at size 9 looks just fine:

Image

I don't have any other operating systems lying around at the moment, but I can try it out on a Windows computer tomorrow.

In the meantime, have you tried reverting (http://www.sublimetext.com/docs/2/revert.html)? This will let you know if any plugins are causing this.

P.S. I laughed when Sublime auto-paired your sad smiley at the end :)
quodlibet
 
Posts: 547
Joined: Sat Jun 18, 2011 5:53 pm

Re: Bold & italic not working with Droid Sans Mono

Postby SeanWcom on Wed Apr 18, 2012 3:32 am

Haha, yeah the autocomplete smily is funny. :)

I just reverted to test things out and the same problem is there. This is far from a deal killer for me. There are lots of good programming fonts out there. :) I just wanted to bring it up in case it did turn out to be a Sublime issue.

Your screenshot makes me want to build up an Ubuntu partition - something about the font rendering makes me a happy coder. lol...
Multiple selections... one of my favorite ST2 features. View some noob-friendly screen casts here.
SeanWcom
 
Posts: 101
Joined: Wed Aug 03, 2011 1:31 am
Location: Georgia

Next

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 32 guests