Home Download Buy Blog Forum Support

[SOLVED] Sublime deleting colour schemes bug

[SOLVED] Sublime deleting colour schemes bug

Postby Fatbat on Tue May 08, 2012 3:29 pm

I had a very weird bug last night that I can't explain. I had an error pop up that basically said the colour scheme that I was using was empty and couldn't be read (sorry, I didn't get a copy of the actual error). At the time I was using my own custom scheme, which thankfully I had a backup of elsewhere. However, when I switched to the default Twilight scheme, it did the exact same thing.

Somehow Sublime was deleting the contents of the scheme files. The files themselves remained, but they were empty and 0k in size. I tried quitting and restarting the app, but the problem persisted. When I would try to copy my scheme back to the folder and then change to that scheme it would seem to load but it would empty itself and the error would pop on the first file that would load. The scheme would turn to a white background with black text. I tried rebooting, copying the scheme, deleting the scheme cache, and finally I reinstalled the app several times. Eventually the problem inexplicably went away. However, uninstalling and reinstalling the app does not replace the Twilight theme that is now missing since I deleted it and its cache.

I'm sorry this is all a bit vague. I really should have got a copy of the error that was popping.
Last edited by Fatbat on Tue May 08, 2012 8:27 pm, edited 1 time in total.
Fatbat
 
Posts: 70
Joined: Sun Feb 19, 2012 6:54 pm

Re: Sublime deleting colour schemes bug

Postby Fatbat on Tue May 08, 2012 7:04 pm

It happened again. This time I choose to update the ColorHighlighter extension because it had stopped working and the moment it completed my scheme was deleted...

Image
Last edited by Fatbat on Tue May 08, 2012 8:27 pm, edited 2 times in total.
Fatbat
 
Posts: 70
Joined: Sun Feb 19, 2012 6:54 pm

Re: Sublime deleting colour schemes bug

Postby Fatbat on Tue May 08, 2012 8:26 pm

Looking through Git this seems to be a problem with the ColorHighlighter extension.
Fatbat
 
Posts: 70
Joined: Sun Feb 19, 2012 6:54 pm

Re: [SOLVED] Sublime deleting colour schemes bug

Postby frankcastro on Wed May 09, 2012 3:01 pm

Hello,

The same happened to me about 2 days ago. I'm on a Macbook. How I solved it was by removing the app, and removing the ~/Library/Application Support/Sublime Text 2 folder, and re-installing Sublime. You can get all the standard Color Schemes here: http://svn.textmate.org/trunk/Themes/

After I re-installed Sublime it has not happened again.

Good luck,

Frank
frankcastro
 
Posts: 2
Joined: Wed May 09, 2012 1:21 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Majestic-12 [Bot] and 23 guests