Home Download Buy Blog Forum Support

ruby: ST simply exits while editing

ruby: ST simply exits while editing

Postby jeremydb on Thu May 10, 2012 8:39 am

I can't narrow this down, because the problem goes away eventually, but I keep running into situations while editing Ruby documents, particularly while modifying regular expressions (e.g. working with '/', '\', and '.' characters), where Sublime Text simply exits. No crash, only a little whimper in the Console:

08.05.12 15:32:50 com.apple.launchd.peruser.501[245] ([0x0-0x13b93b8].com.sublimetext.2[41258]) Exited abnormally: Broken pipe

Relauching and attempting the edit yields an identical exit. At some point, I give up and use TextMate for a while. And then eventually it stops, until it starts again. This occurs with the most recent nightly, but it's been a problem I've experienced semi-regularly, with many versions.

I wish I could offer more information. Is there a log file I can send you?

Thanks -
Jeremy
jeremydb
 
Posts: 9
Joined: Thu May 12, 2011 1:08 pm

Re: ruby: ST simply exits while editing

Postby jps on Thu May 10, 2012 12:30 pm

This looks like an unresolved issue with the SublimeCodeIntel plugin
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: ruby: ST simply exits while editing

Postby jeremydb on Fri May 11, 2012 8:12 am

jps wrote:This looks like an unresolved issue with the SublimeCodeIntel plugin


Oh, oops. I didn't realize I still had that installed. Sorry for the noise.

jb
jeremydb
 
Posts: 9
Joined: Thu May 12, 2011 1:08 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 17 guests