Home Download Buy Blog Forum Support

Preferences not loading

Preferences not loading

Postby twistedweasel on Thu May 10, 2012 2:56 pm

I am not sure when it happened, but at some point my default global preferences stopped loading. No changes I make in there seem to affect anything although my user settings work just fine.

I have used a symbolic link to put these files into my Dropbox folder so I wonder if that is causing issues. I looked in the console and the only error I saw that looked relevant was:

packages path: /Users/fhg/Library/Application Support/Sublime Text 2/Packages
settings path: /Users/fhg/Library/Application Support/Sublime Text 2/Settings
error parsing session: No data at: 0:0


I am on the latest stable OSX build. Has anyone else seen this issue?

Fraser
twistedweasel
 
Posts: 1
Joined: Thu May 10, 2012 2:47 pm

Re: Preferences not loading

Postby ivow on Sat Jul 14, 2012 5:39 am

I had the same thing happening over here. I think it's necessary that all the package folders (Installed Packages, Packages & Pristine Packages) have to stay together.

In my first try I had only the "Packages" folder in Dropbox.

How I fixed it was to backup my settings, freshly installed Sublime Text 2, copy/pasted my settings in. And then copied the 3 folders to Dropbox & symlinked them.

Hope this will help you.

Cheers
ivow
 
Posts: 1
Joined: Sat Jul 14, 2012 5:33 am

Re: Preferences not loading

Postby jps on Sat Jul 14, 2012 7:25 am

What's the file name that you're editing? The file name was changed during the beta, when the two separate preferences files were combined. It should be Preferences.sublime-settings.
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 27 guests