Home Download Buy Blog Forum Support

Ballooning Memory Usage [Sublime 1 Beta 20101013]

Ballooning Memory Usage [Sublime 1 Beta 20101013]

Postby knrd on Wed May 30, 2012 4:32 pm

Over the past couple of weeks I noticed sublime consuming considerably more memory, without any changes on my end. Before it would sit comfortably at ~150 MB with a few dozen files opened, whereas now it's at 600-800 MB when I check the task manager (due to bad performance). From what I can gather it appears to be an issue with the buffer, as any operation that involves moving tabs/files or switching panes increases memory usage. Cycling through the tabs does the trick, as does moving files from pane 1 to 2 or simply switching from pane 1 to 2.

As I mentioned at the beginning, I have been using sublime as is with the same exact plugins, settings and preferences since late 2010. Nothing on my system changed either since beginning of 2011. I also just tried uninstalling sublime and removing all old settings. However just with a clean uninstall I can replicate the issue. It seems every time I move panes, files or the current active buffer, the memory usage increases.

System:

Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz
8 GB RAM, HD3000 GPU

Win 7 x64 SP1 with the latest patches, MSE

Let me know if you need anything else.

Thanks
knrd
 
Posts: 7
Joined: Sun Aug 21, 2011 8:23 pm

Re: Ballooning Memory Usage [Sublime 1 Beta 20101013]

Postby quarnster on Wed May 30, 2012 4:36 pm

Why are you using Sublime 1?
quarnster
 
Posts: 389
Joined: Tue Nov 29, 2011 11:34 am

Re: Ballooning Memory Usage [Sublime 1 Beta 20101013]

Postby knrd on Thu May 31, 2012 12:22 pm

I'm happy with v1 and there's a couple of things within v2 that annoy me and that I can't change (for example, animating the file tab when moving it from one pane to the other).

But ultimately I paid for v1 and telling me to use v2 is not really helping with the issue.
knrd
 
Posts: 7
Joined: Sun Aug 21, 2011 8:23 pm

Re: Ballooning Memory Usage [Sublime 1 Beta 20101013]

Postby quarnster on Thu May 31, 2012 12:53 pm

Given that there's no download links for version 1 anymore, I don't think it's supported.
quarnster
 
Posts: 389
Joined: Tue Nov 29, 2011 11:34 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 25 guests