Home Download Buy Blog Forum Support

/bin/sh: bundle: command not found Ruby Test

/bin/sh: bundle: command not found Ruby Test

Postby 6e0r9e on Thu Jun 28, 2012 4:21 am

Hi,

I am trying to run ruby test on sublime text 2 and I keep getting this error: /bin/sh: bundle: command not found
I have this file RubyTest.sublime-settings in the sublime package directory. I also created a bin folder and in that folder I created an sh folder with that file in it. I
tried opening subl through terminal and even through terminal I get that message. This is the code in the file :

{
"erb_exec": "bundle exec erb",
"ruby_unit_exec": "bundle exec ruby",
"ruby_cucumber_exec": "bundle exec cucumber -f pretty",
"ruby_rspec_exec": "bundle exec rspec",

"ruby_unit_folder": "test",
"ruby_cucumber_folder": "features",
"ruby_rspec_folder": "spec"
}

This has nothing to do with rspec but just in case if I run rspec $ which rspec I get this :/Users/6e0r9e/.rvm/gems/ruby-1.9.3-p194@rails3tutorial2ndEd/bin/rspec
I just want to have ruby test working.
6e0r9e
 
Posts: 1
Joined: Thu Jun 28, 2012 4:07 am

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 13 guests