Home Download Buy Blog Forum Support

Auto completion on tab refuses to go away

Auto completion on tab refuses to go away

Postby astrogee on Thu Jun 28, 2012 7:00 am

Since a few builds back it seems like ST2 is ignoring this setting

Code: Select all
"auto_complete_commit_on_tab": false


..as it will always commit an auto complete suggestion when I press tab. I've tried setting "tab_completion" to both true and false with the same effect. I don't know if I have unwittingly added something to the default key map, but that file is overwritten when you install a new build, right? This is what I have in the Default keymap (windows). The first line there looks a bit fishy to me. I don't have any settings for "tab" in my user key map

Code: Select all
   { "keys": ["tab"], "command": "insert_best_completion", "args": {"default": "\t", "exact": true} },
   { "keys": ["tab"], "command": "insert_best_completion", "args": {"default": "\t", "exact": false},
      "context":
      [
         { "key": "setting.tab_completion", "operator": "equal", "operand": true }
      ]
   },
   { "keys": ["tab"], "command": "replace_completion_with_next_completion", "context":
      [
         { "key": "last_command", "operator": "equal", "operand": "insert_best_completion" },
         { "key": "setting.tab_completion", "operator": "equal", "operand": true }
      ]
   },
   { "keys": ["tab"], "command": "reindent", "context":
      [
         { "key": "setting.auto_indent", "operator": "equal", "operand": true },
         { "key": "selection_empty", "operator": "equal", "operand": true, "match_all": true },
         { "key": "preceding_text", "operator": "regex_match", "operand": "^$", "match_all": true },
         { "key": "following_text", "operator": "regex_match", "operand": "^$", "match_all": true }
      ]
   },
   { "keys": ["tab"], "command": "indent", "context":
      [
         { "key": "text", "operator": "regex_contains", "operand": "\n" }
      ]
   },
   { "keys": ["tab"], "command": "next_field", "context":
      [
         { "key": "has_next_field", "operator": "equal", "operand": true }
      ]
   },
   { "keys": ["tab"], "command": "commit_completion", "context":
      [
         { "key": "auto_complete_visible" },
         { "key": "setting.auto_complete_commit_on_tab" }
      ]
   },


So bottom line: I don't want auto complete commit on the tab key, but I want it on the enter key. 'tis driving me nuts. :shock: Can anyone help?
astrogee
 
Posts: 6
Joined: Tue Feb 07, 2012 9:55 am

Re: Auto completion on tab refuses to go away

Postby cfsimplicity on Thu Jul 11, 2013 9:23 am

You can workaround this by adding a mapping to your user key bindings file:

http://www.sublimetext.com/forum/viewtopic.php?f=3&t=7590&p=50932#p50932
cfsimplicity
 
Posts: 2
Joined: Tue Jul 09, 2013 10:52 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 19 guests