Home Download Buy Blog Forum Support

Poor performance on 2nd display

Poor performance on 2nd display

Postby chedabob on Thu Mar 20, 2008 9:53 am

When I run sublime text on my 2nd display, it gets very laggy. I've made sure hardware acceleration is enabled for that display. I think it might be caused by the text on the statusbar (that seems to be updating when the lag occurs). I'm running Ati Radeon X1950 Pro with the latest drivers on XP X64 Pro.
chedabob
 
Posts: 2
Joined: Thu Mar 20, 2008 9:50 am

Re: Poor performance on 2nd display

Postby jps on Thu Mar 20, 2008 11:15 am

This sounds like one of the Direct3D quirks - if you create a d3d device on a window on one monitor, then move the window to another monitor, things start running really slowly. Sublime tries to detect this and recreate the device when it's moved from one monitor to another but perhaps that's not working correctly in this case.

Can I get you to:
* Check that the window isn't spanning multiple monitors, this will always cause a slowdown.
* Move the window onto your 2ed display, exit, then restart, and see if it's still slow. This will create the window directly on the correct monitor, and so won't rely on any logic to detect a change of monitor.

If neither of these clear it up, I'll make the OpenGL renderer a command line option for the next beta, which doesn't (at least for me) have any slow down issues associated with moving windows between monitors, spanning monitors, etc.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Poor performance on 2nd display

Postby jps on Thu Mar 27, 2008 2:29 pm

For reference, I spoke to chedabob via email, and having Sublime start on the second display resolved the issue.

Couple of other notes:
* There are no issues with moving or spanning d3d windows between monitors on Vista.
* There are also no issues of the same kind on XP when running in opengl mode, which you can use via adding --opengl to the command line.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 30 guests