Home Download Buy Blog Forum Support

Selection -> Add Next Line keyboard shortcut not working

Selection -> Add Next Line keyboard shortcut not working

Postby rpardee on Wed Jul 11, 2012 8:55 pm

I can do column-select by mousing my way to Selection -> Add Next Line, but the keyboard shortcut listed (ctrl+alt+down) has no effect whatever. Same deal with Add Previous Line. I'm running v2.0 build 2210 on 32-bit windows xp. Can anyone help?

Thanks!

-Roy
rpardee
 
Posts: 29
Joined: Wed Jul 11, 2012 8:51 pm

Re: Selection -> Add Next Line keyboard shortcut not working

Postby rpardee on Sun Jul 15, 2012 8:12 pm

Anyone? I just now un- and re-installed & no difference. (So I'm on 2.01 now)

If I do sublime.log_input(True) in the console & watch as I press keys, I get nothing if I press ctrl-alt-up. ctrl-up registers, and alt-up, but ctrl-alt-up gives nothing.

The x64 version running on win7 does not have this problem.

Can someone help? I'd really like to make this my main editor...

Thanks!

-Roy
rpardee
 
Posts: 29
Joined: Wed Jul 11, 2012 8:51 pm

Re: Selection -> Add Next Line keyboard shortcut not working

Postby jps on Tue Jul 17, 2012 2:45 pm

IIRC nvidia drivers can sometimes intercept this key combination
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

RESOLVED: Selection->Add Next Line keyboard shortcut not wor

Postby rpardee on Tue Jul 17, 2012 6:42 pm

jps wrote:IIRC nvidia drivers can sometimes intercept this key combination

Genius! Thank you!

I don't have nvidia drivers, but I do have an intel "Graphics Media Accelerator Driver For Mobile" program, which has a toggle to enable its hot keys for e.g., turning on & off the laptop & external displays. Those hotkeys don't include ctrl-alt-up/down, but the do all start with ctrl-alt and when I disable them sublime starts getting these keypresses & acts accordingly. So I'm fixed.

Thanks so much!
rpardee
 
Posts: 29
Joined: Wed Jul 11, 2012 8:51 pm

Re: Selection -> Add Next Line keyboard shortcut not working

Postby nick. on Tue Jul 31, 2012 3:23 am

Happened here as well. Thanks for the fix.
nick.
 
Posts: 266
Joined: Wed Jan 18, 2012 3:45 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 23 guests