Home Download Buy Blog Forum Support

Can't run newer builds on Linux

Can't run newer builds on Linux

Postby jalb on Sat Aug 04, 2012 1:41 am

Hi, I use Sublime Text 2 for my cross platform development and am regularly using the application on Windows, Linux and OSX. I have never had any issues up until lately. I've neglected to update to the newest version, 2.0.1, until just recently due to the constant popup reminding me there's a new version. I upgraded just fine on both OSX and Windows but the Linux build will not run. I have also tried the latest nightly build, 2218, and I am having the same problem.

This is what happens when I try to run via konsole:
Image

It may be worth noting that I was trying to get SublimeClang working and I followed their steps on getting the plugin to work in Linux:
curl -kL http://xrl.us/pythonbrewinstall | bash
source "$HOME/.pythonbrew/etc/bashrc"
pythonbrew install --configure="--enable-unicode=ucs4" 2.6
ln -s $HOME/.pythonbrew/pythons/Python-2.6/lib/python2.6/ <your Sublime Text 2 folder>/lib/python2.6


These steps did not make the plugin work, however, and may of broken something in the newer builds. I have tried to re-install Sublime Text 2 entirely (deleting everything in the .config folder and the "Sublime Text 2" folder that I downloaded) and the problem persisted. The pythonbrew application sets the PYTHONPATH environment variable to where it downloads python, but also has the "pythonbrew off" command which sets that back to "". This did not solve the problem either.

Any help would be greatly appreciated.

If it matters, I am using Ubuntu 64bit with KDE.
jalb
 
Posts: 1
Joined: Sat Aug 04, 2012 1:19 am

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], ninjaroll and 28 guests