Home Download Buy Blog Forum Support

Issues running SublimeGDB

Issues running SublimeGDB

Postby Feversaint on Thu Aug 16, 2012 1:16 pm

I was looking for a way to use a c++ debugger in ST when I found SublimeGDB which appears to be everything I need. I installed it through Package Control.

When I try to run a simple hello world program (which builds/runs fine otherwise), it appears as though nothing happens, ST just sits there. I tried inserting breakpoints but it still wouldn't run.

I used "sublime.log_commands(True)" in the console and when I run SublimeGDB the following appears:

Code: Select all
command: gdb_launch
Traceback (most recent call last):
  File ".\sublime_plugin.py", line 339, in run_
  File ".\sublimegdb.py", line 1381, in run
  File ".\sublimegdb.py", line 74, in expand_path
  File ".\re.py", line 151, in sub
  File ".\re.py", line 273, in _subx
  File ".\re.py", line 258, in _compile_repl
  File ".\sre_parse.py", line 700, in parse_template
  File ".\sre_parse.py", line 187, in __init__
  File ".\sre_parse.py", line 189, in __next
TypeError: object of type 'NoneType' has no len()


I have zero experience with python and am just starting to explore ST's functionality. I don't know if this is a bug in SublimeGDB (it was just updated 5 hours ago), or if I'm just running it wrong somehow (do I need to set up a project in a specific way or something to that effect?). To run it I bring the file I want into focus and hit F5.

Thanks for your time!
Feversaint
 
Posts: 1
Joined: Thu Aug 16, 2012 1:07 pm

Return to Technical Support

Who is online

Users browsing this forum: Alexa [Bot], Google [Bot], TurnitinBot [Bot] and 24 guests