Home Download Buy Blog Forum Support

Linux Cut&Paste Problem (XFCE)

Linux Cut&Paste Problem (XFCE)

Postby wlbr on Fri Aug 17, 2012 8:50 am

Hi,

on Linux running XFCE and a current Sublime it is not possible to use the cut&paste function. The text ist cut, but actually not transferred to the clipboard. Every second try will work, that means a Cut - Undo - Cut - Paste or a Copy - Cut - Paste works. Nevertheless, this is not a viable solution and prevents people from using Sublime on Linux.

Bug is well known.

A workaround is to kill the process xfce4-settings-helper. Then Sublimes cut&paste function works as desired, but unfortunately all the keyboard shortcuts of XFCE are gone. Again a not viable workaround.

Some maybe new information:
Eclispe 3.% had the same problem, see the bugzilla link here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=153809
It was solved with 3.6 and later. That means after long discussion it was recognized, that this is not a problem of XFCE, but of the applications (Eclipse or Sublime) clipboard handling.

I guess you will find more information within the Eclipse bug description.

Hope to see that issue solved, without it, currently Sublime is not useable.

Thanks,
Michael
wlbr
 
Posts: 1
Joined: Fri Aug 17, 2012 8:18 am

Re: Linux Cut&Paste Problem (XFCE)

Postby stestagg on Wed Jan 09, 2013 6:09 pm

I think this is due to this XFCE bug:

https://bugzilla.xfce.org/show_bug.cgi?id=6521

I was able to fix the issue (temporarily) in sublime by running:

pkill -f xfsettingsd

to kill the xfce settings daemon, which poorly intercepts clipboard events.

I'm not entirely sure what the side-effects of doing this are, but nothing too bad seems to have happened yet.
stestagg
 
Posts: 3
Joined: Wed Jan 09, 2013 6:07 pm

Re: Linux Cut&Paste Problem (XFCE)

Postby stestagg on Wed Jan 09, 2013 6:30 pm

Sorry, This seems not to have been true. Since posting this, the issue has returned and xfsettingsd may be causing it, but killing it properly is harder than seems.

My current attempt is to install parcellite, a clipboard manager. So far this is preventing the problem from happening
stestagg
 
Posts: 3
Joined: Wed Jan 09, 2013 6:07 pm

Re: Linux Cut&Paste Problem (XFCE)

Postby bianc0niglio on Fri Apr 19, 2013 9:32 am

I think I have nailed it.
For the XFCE users: just close your Clipman applet and retry. It should work flawlessly.

I think it's some sort of run condition on the clipboard management between the applet and the editor.
bianc0niglio
 
Posts: 2
Joined: Fri Apr 19, 2013 9:25 am

Re: Linux Cut&Paste Problem (XFCE)

Postby zenolijo on Sat Oct 05, 2013 1:45 pm

Simply turning off clipman works for me too!
zenolijo
 
Posts: 1
Joined: Sat Oct 05, 2013 1:43 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 25 guests