Home Download Buy Blog Forum Support

Problem with .tmLanguage...?

Problem with .tmLanguage...?

Postby harblcat on Thu Nov 19, 2009 9:10 am

Hi all. I have a problem.

I'm using the Clojure .tmLanguage available at GitHub here (not mine, just using it). However, I find that it freezes Sublime, whenever I type in the following:
(defn
This is as far as I can type, and then it freezes up. I don't know what the issue is, and have tried the .tmLanguage in e-texteditor, where it works just fine. Are there any things I could be doing wrong, does the language grammar need a little tweaking for Sublime?

Thanks for any help!
harblcat
 
Posts: 1
Joined: Thu Nov 19, 2009 9:04 am

Re: Problem with .tmLanguage...?

Postby jps on Thu Nov 26, 2009 10:55 pm

It's working ok for me, can you let me know which version of Clojure.tmLanguage you're using (the latest one from github?), and which version of Sublime Text you're using.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Problem with .tmLanguage...?

Postby Bizarro on Mon Apr 11, 2011 4:12 pm

Hello!

I'm having the same problem with Sublime Text 2 Alpha, Build 2051, and the latest version of Clojure.tmLanguage from this link http://github.com/vishnugopal/clojure-tmbundle/blob/master/Syntaxes/Clojure.tmLanguage (Here you can see that the file was last modified on December 14, 2008). If I try to open a .clj file which has any function definition like "(defn dummy [params] ... )", Sublime Text freezes. And if I write "(defn " it also freezes.
Why could this be happening?

I have tried using another .tmLanguage file I have found here, which appears to be more recent: was last modified on September 29, 2010. But it also freezes Sublime whenever I write "(defn ".

I'm trying to help and fix this myself by editing the .tmLanguage file, but everything I've tried has not worked.
I don't know what to do.
Anyone has any idea?
Thank you very much for your help!
Bizarro
 
Posts: 2
Joined: Tue Oct 27, 2009 3:30 pm
Location: Spain

Re: Problem with .tmLanguage...?

Postby Bizarro on Tue Apr 12, 2011 4:02 pm

Hi!
I have just tested this with Sublime Text 1.4 (Build 2010-10-13) and Sublime Text 2 (Build 2054), and the problem is still there. :cry:
Writing "(defn " hangs boths versions of the program.

I'll keep investigating... (¿could it be a problem with the syntax .tmLanguage file?).

Any help will be very appreciated! :D
Thanks.
Bizarro
 
Posts: 2
Joined: Tue Oct 27, 2009 3:30 pm
Location: Spain

Re: Problem with .tmLanguage...?

Postby malfario on Thu Jun 09, 2011 4:00 pm

I know this is an old thread, but came across to it while searching for a solution to this problem to no avail.
I've fixed the Var creation bugs (also defn, defmacro, defmulti, defmacro, etc.) and started a project at github:

https://github.com/malfario/sublime-clojure

Cheers!
malfario
 
Posts: 1
Joined: Thu Jun 09, 2011 3:49 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 30 guests