Home Download Buy Blog Forum Support

Unable to Determine / Define Version of Ruby for Builds

Unable to Determine / Define Version of Ruby for Builds

Postby kries0117 on Fri Sep 14, 2012 11:32 pm

I'm having difficulty determining what version of Ruby SublimeText 2 is using for my builds. I tried the following advice http://upstre.am/blog/2011/07/sublime-text-2-with-rvm-on-osx/ to get Sublime Text 2 to use the RVM version of Ruby, but now when I run my builds, I get the following error:

[Errno 2] No such file or directory
[cmd: [u'/Users/MY_USERNAME/bin/sublime_rvm.rb', u'/Users/MY_USERNAME/studio_game/player.rb']]
[dir: /Users/MY_USERNAME/studio_game]
[path: /usr/bin:/bin:/usr/sbin:/sbin]
[Finished]

I also changed the Ruby.sublime-build package to:

{
"cmd": ["/Users/kyleries/bin/sublime_rvm.rb", "$file"],
"file_regex": "^(...*?):([0-9]*):?([0-9]*)",
"selector": "source.ruby"
}

If someone could send me the original build package cmd line, that would be great, and I can try to revert back that way. Thanks!
kries0117
 
Posts: 1
Joined: Fri Sep 14, 2012 11:28 pm

Re: Unable to Determine / Define Version of Ruby for Builds

Postby agaviria on Wed Oct 10, 2012 3:28 pm

I'd like to second this request [Errno2].
I'm in the same boat and can't seem to build Ruby 1.9 in SublimeText2. :cry:
The only difference is that my path reads differently:
[path: /usr/local/bin:/usr/bin:/usr/sbin:/sbin]

@kries0117: :?: where you able to get by this error? What steps did you perform to correct this issue?
agaviria
 
Posts: 1
Joined: Wed Oct 10, 2012 3:14 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 34 guests