Home Download Buy Blog Forum Support

100% CPU on "Updating Indexes..."

100% CPU on "Updating Indexes..."

Postby juxtapos on Wed Oct 10, 2012 7:19 pm

I'm generally a super-happy Sublime user and customer (2.0.1, 2217), but the behavior it had for the last week or so is really annoying. Sublime does a frequent (like every 10, 15 mins) "Updating Indexes...", that drives my CPU on a Macbook Air 1.6Ghz, 4Gb Ram to 100%. Sublime is still usable, but the cursor is lagging, tab switching is slow. I'm working on a node.js project, which currently has 39Mb, most of it being npm dependencies, so, it's many and small files. I really hope to get some help, the constant spinning of the fan is driving me nuts and I really don't want to switch back to one these inferior text editors available on OS X :-)

Thanks in advance,

Claus
juxtapos
 
Posts: 1
Joined: Wed Oct 10, 2012 6:42 pm

Re: 100% CPU on "Updating Indexes..."

Postby agibsonsw on Wed Oct 10, 2012 7:29 pm

Just guessing, but it might be SublimeCodeIntel or some other plug-in causing this issue.
"I'm here to save your life. But if I'm going to do that, I'll need total uninanonynymity." Me Myself & Irene.
agibsonsw
 
Posts: 901
Joined: Fri Jan 27, 2012 9:11 pm

Re: 100% CPU on "Updating Indexes..."

Postby Lukk on Wed Aug 14, 2013 9:52 pm

Alright I changed the symbol list but it's still not working :( maybe I've done something wrong?

I added the code you listed to the symbol list file from the sass plugin with the PackageResourceViewer (awesome plugin btw!). Maybe I should re-index the files from the project or something? But I don't know how to do that.
Lukk
 
Posts: 12
Joined: Sun Mar 18, 2012 1:41 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 18 guests

cron