Home Download Buy Blog Forum Support

Text not rendered properly under mint

Text not rendered properly under mint

Postby tapochki on Mon Oct 15, 2012 4:06 am

I am running Mint 13 with Mate (ATI HD7850). Sublime doesn't render the text properly when I scroll or try to type anything.
I've tried both the 2217 and 2220 builds, any suggestions.
Attachments
sublime.png
sublime.png (86.04 KiB) Viewed 2735 times
tapochki
 
Posts: 3
Joined: Mon Oct 15, 2012 4:01 am

Re: Text not rendered properly under mint

Postby Eduan on Mon Oct 15, 2012 1:24 pm

Hi,

Does the same happen with the default Sublime Text 2 theme? Or the default Monokai color scheme? Please tell us the results, remember to restart Sublime Text 2 so that the other one doesn't interfere at all. ;)
Check out my blog and website: EduanTech.com (currently undergoing some facial and organs makeover...)
Also check out my profiles: GitHub - Greduan | BitBucket - Greduan
Eduan
 
Posts: 140
Joined: Sun Oct 14, 2012 4:05 pm

Re: Text not rendered properly under mint

Postby tapochki on Tue Oct 16, 2012 4:21 am

This happens under all color schemes, I've restarted st2 as suggested when changing them and the issue persists.
The text is rendered improperly in the left hand file selection column as well.

All the other applications including other editors (eclipse..etc) function correctly.
tapochki
 
Posts: 3
Joined: Mon Oct 15, 2012 4:01 am

Re: Text not rendered properly under mint

Postby Eduan on Tue Oct 16, 2012 1:13 pm

Hmm... I've experienced this problem before, but with a browser. I solve it by refreshing the page, like moving around the file for it to update, or turn on&off the monitor.

Although it may also be a package conflict with another package, so what you might want to try is to un-install all your packages, and see if that solves the problem. If it doesn't then you can re-install them all and, could you please give us your system details? Maybe so that John can reproduce the issue. :)

- Eduan
Check out my blog and website: EduanTech.com (currently undergoing some facial and organs makeover...)
Also check out my profiles: GitHub - Greduan | BitBucket - Greduan
Eduan
 
Posts: 140
Joined: Sun Oct 14, 2012 4:05 pm

Re: Text not rendered properly under mint

Postby serialhex on Thu Oct 18, 2012 4:02 am

i just did an update on my archlinux machine & it does the same thing. everything else works fine though. one thing it might be is vid card drivers? i'm running an amd radeon hd 6400m with the catalyst drivers (module fglrx) if the orig poster has the same vid & drivers we might be on to something (if not, we'll have to figure something else out!)
serialhex
 
Posts: 5
Joined: Thu Oct 18, 2012 3:56 am

Re: Text not rendered properly under mint

Postby tapochki on Thu Oct 18, 2012 7:45 am

Yep, running the same drivers as you (ATI HD 7850 with catalyst driver).
tapochki
 
Posts: 3
Joined: Mon Oct 15, 2012 4:01 am

Re: Text not rendered properly under mint

Postby serialhex on Thu Oct 18, 2012 4:32 pm

Okay, so we have similar drivers for our video cards, some of the output of `dmesg | grep fglrx` is:

serialhex@multi-hex [~]$ dmesg | grep fglrx
[ 1.845547] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[ 1.878311] <6>[fglrx] Maximum main memory to use for locked dma buffers: 5776 MBytes.
[ 1.878559] <6>[fglrx] vendor: 1002 device: 6760 count: 1
[ 1.878882] <6>[fglrx] ioport: bar 4, base 0x9000, size: 0x100
[ 1.879025] <6>[fglrx] Kernel PAT support is enabled
[ 1.879048] <6>[fglrx] module loaded - fglrx 9.0.2 [Sep 20 2012] with 1 minors
...

if yours is the same then it might be a video card thing. i tried some opengl accelerated stuff (things from xscreensaver) thinking it might be some wonky stuff in rendering (i semi-remember something about using opengl to make rendering spiffier... though i could be hallucinating things) and that worked fine. I'm not sure what other information to provide at this time, let me knowwhat else i can do to resolve this. (i'm going to try rolling back my drivers... see if that works)
serialhex
 
Posts: 5
Joined: Thu Oct 18, 2012 3:56 am

Re: Text not rendered properly under mint

Postby serialhex on Sat Oct 20, 2012 3:08 am

I tried rolling back my catalyst drivers - that would be too much of a pain so i stopped & tried the opensource drivers, and they work!! so it's not a problem in sublime text!! (and i can get back to work!)
serialhex
 
Posts: 5
Joined: Thu Oct 18, 2012 3:56 am

Re: Text not rendered properly under mint

Postby mikeshultz on Sun Oct 21, 2012 3:01 pm

I'm having the same problem on Arch Linux and it makes sublime unusable. Tried the latest dev build, with the same problem. Tried changing color themes, also with no luck.

Rolling back catalyst(and X and the kernel) would take a ridiculous amount of time and hassle. And the open source radeon drivers are not an option on my machine.

So, if the problem isn't with sublime, could someone give me a clue as to library dependencies or things to try?
mikeshultz
 
Posts: 1
Joined: Sun Oct 21, 2012 2:54 pm

Re: Text not rendered properly under mint

Postby serialhex on Thu Oct 25, 2012 3:04 am

I've been using the open source drivers & they seem to be overheating my system! it would be one thing if this was a tower, i could live with the noise & extra few degrees, but this is a laptop, and is *WAY* not cool!!! i would very much like to switch back to the catalyst drivers, and keep using sublime... any suggestions???
serialhex
 
Posts: 5
Joined: Thu Oct 18, 2012 3:56 am

Next

Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 42 guests