Home Download Buy Blog Forum Support

Disable "Smart Home" behaviour

Disable "Smart Home" behaviour

Postby GreyWyvern on Mon Nov 09, 2009 5:02 pm

While I can probably get used to it, it would be helpful to allow disabling the "smart home" behaviour for those upgrading to Sublime Text from a low-level editor like Notepad or Metapad.

Smart home is where you press the Home key to move the cursor to the first non-whitespace character in the line, rather than placing the cursor at column 1. Yesh, I know a second press of the Home key will then move the cursor to column 1, but my muscle-memory for a lot of common operations is going to be a tough habit to break. Hitting Home, then holding shift and arrow-key selecting whole lines is the first thing that comes to mind.

Disabling smart home should mean that pressing Home moves the cursor to column 1, and further pressing of the Home key will keep the cursor there, rather than toggling between column 1 and the first non-whitespace character.

Cheers!
GreyWyvern
 
Posts: 106
Joined: Fri Oct 23, 2009 7:08 pm
Location: Canadia

Re: Disable "Smart Home" behaviour

Postby myel on Mon Nov 09, 2009 6:52 pm

hey,

it already can be configured (you'll need the latest beta) :).

just a add the follwing line to your key binding (user key bindings)

Code: Select all
<binding key="home" command="moveTo hardbol"/>
myel
 
Posts: 88
Joined: Sat Mar 22, 2008 11:26 pm

Re: Disable "Smart Home" behaviour

Postby GreyWyvern on Mon Nov 09, 2009 8:13 pm

This works. Thanks for the reply! :)
GreyWyvern
 
Posts: 106
Joined: Fri Oct 23, 2009 7:08 pm
Location: Canadia

Re: Disable "Smart Home" behaviour

Postby jps on Mon Nov 09, 2009 8:53 pm

You'll probably want the full complement, to keep things consistent:

Code: Select all
   <binding key="home" command="moveTo hardbol"/>
   <binding key="shift+home" command="moveTo hardbol extend"/>
   <binding key="end" command="moveTo hardeol"/>
   <binding key="shift+end" command="moveTo hardeol extend"/>


(hardeol is there because it has the same behaviour with respect to word wrapping that hardbol does)
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: Disable "Smart Home" behaviour

Postby GreyWyvern on Mon Nov 09, 2009 8:56 pm

This is exactly what I need. Thanks again!
GreyWyvern
 
Posts: 106
Joined: Fri Oct 23, 2009 7:08 pm
Location: Canadia


Return to Ideas and Feature Requests

Who is online

Users browsing this forum: No registered users and 12 guests