Home Download Buy Blog Forum Support

Indent XML

Re: Indent XML

Postby alek_sys on Thu Nov 17, 2011 6:30 pm

Okey, just got MacOS virtual machine and installed sublime + indent XML via "package control".

It seems it works fine. Just to clarify - recently one good man added keyboard shortcut for Mac so try first update package (if it wasn't happened automatically). Second, key combination is super+k (hold super!) super+f. So first press super then k then f. This should work. Or open console and type view.run_command("indentxml")

Regards, Alexey.
Posts: 7
Joined: Thu Nov 17, 2011 3:22 pm

Re: Indent XML

Postby sfinx on Wed Feb 01, 2012 8:36 am

Hi, just tried to use Ident XML on Sublime Text 2 beta 2165 on Ubuntu Oneiric Ocelot 64 bit. It installs just fine, but when I try to use it I get this error in the console:

Code: Select all
Traceback (most recent call last):
  File "./sublime_plugin.py", line 351, in run_
    return self.run(edit)
  File "./indentxml.py", line 32, in run
  File "./indentxml.py", line 48, in indentxml
  File ".\xml\dom\minidom.py", line 1927, in parseString
  File ".\xml\dom\expatbuilder.py", line 32, in <module>
  File ".\xml\parsers\expat.py", line 4, in <module>
ImportError: No module named pyexpat

Any ideas? The module is installed just fine in my regular Python (2.6 and 2.7) install.
Posts: 1
Joined: Wed Feb 01, 2012 8:33 am

Re: Indent XML

Postby watusimoto on Fri Oct 12, 2012 2:22 pm

This fixed the problem for me...

$ sudo apt-get install python2.6
$ ln -s /usr/lib/python2.6 [Sublime Text dir]/lib/

Found this tip on GitHub somewhere.
Posts: 5
Joined: Mon Sep 17, 2012 12:47 pm

Re: Indent XML

Postby stoo on Thu Aug 20, 2015 5:42 pm

Traceback (most recent call last):
File "./sublime_plugin.py", line 362, in run_
File "./indentxml.py", line 51, in run
File "./indentxml.py", line 100, in indent
ImportError: No module named pyexpat

in Ubuntu 15.04

I've tried using $ sudo ln -s /usr/lib/python2.7 /opt/sublime_text_2/lib/

So in /opt/sublime_text_2/lib I have a python2.7 file that ought to link to /usr/lib/python2.7, but the error persists

Am I doing something wrong?
Posts: 1
Joined: Thu Aug 20, 2015 5:39 pm


Return to Plugin Announcements

Who is online

Users browsing this forum: No registered users and 7 guests