Home Download Buy Blog Forum Support

Xiki Support in Sublime (With Incentive)

Re: Xiki Support in Sublime (With Incentive)

Postby roblight on Wed Sep 19, 2012 6:31 pm

What's the best/easiest way to install?

Thanks so much for your hard work on this!
roblight
 
Posts: 13
Joined: Fri Jul 08, 2011 2:25 am

Re: Xiki Support in Sublime (With Incentive)

Postby S0und on Thu Sep 27, 2012 8:20 am

roblight wrote:What's the best/easiest way to install?

Thanks so much for your hard work on this!



package control: add reposity -> https://github.com/lunixbochs/SublimeXiki (paste this)

package control: install package -> SublimeXiki
S0und
 
Posts: 70
Joined: Wed Oct 28, 2009 4:12 pm

Re: Xiki Support in Sublime (With Incentive)

Postby roblight on Thu Oct 04, 2012 12:57 pm

S0und wrote:package control: add reposity -> https://github.com/lunixbochs/SublimeXiki (paste this)

package control: install package -> SublimeXiki


That worked nicely! Never added a repo to package control before. I assume I can use package control to update the package when a new one comes out.

Thanks so much!
roblight
 
Posts: 13
Joined: Fri Jul 08, 2011 2:25 am

Re: Xiki Support in Sublime (With Incentive)

Postby lumbergh on Thu Oct 04, 2012 3:54 pm

Great idea! Would happily donate to this project/developer.

Doesn't seem to work well if you use RVM on OS X to manage your Rubies, though... Might be a general problem in Sublime, though, but it runs my other ruby code in-editor just fine with the "build" command... Here's the error from running "docs":

Code: Select all
docs
  /Users/lumbergh/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find xiki (>= 0) amongst [bigdecimal-1.1.0, io-console-0.3, json-1.5.4, minitest-2.5.1, rake-0.9.2.2, rdoc-3.9.4] (Gem::LoadError)
    from /Users/lumbergh/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
    from /Users/lumbergh/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems.rb:1231:in `gem'
    from /Users/lumbergh/.rvm/gems/ruby-1.9.3-p194/bin/xiki:18:in `<main>'
lumbergh
 
Posts: 1
Joined: Thu Oct 04, 2012 3:51 pm

Re: Xiki Support in Sublime (With Incentive)

Postby lunixbochs on Thu Oct 04, 2012 8:05 pm

Try the latest commit.

If the `xiki` shell command still can't reliably run, you need to edit /usr/local/bin/xiki shebang with the full path to a ruby install that can run it.

Re: easiest way to install;
It's now in Package Control.
lunixbochs
 
Posts: 91
Joined: Fri Oct 08, 2010 10:18 pm

Re: Xiki Support in Sublime (With Incentive)

Postby sublimator on Tue Oct 09, 2012 6:34 pm

No $500 for Lunix?
It is better to remain silent and be thought a fool, than to speak out and remove all doubt
sublimator
 
Posts: 649
Joined: Thu Mar 20, 2008 5:41 am

Previous

Return to Plugin Development

Who is online

Users browsing this forum: Majestic-12 [Bot] and 4 guests