Home Download Buy Blog Forum Support

[resolved] V2 - Build 2065 - cannot execute binary file

[resolved] V2 - Build 2065 - cannot execute binary file

Postby guiohm on Sun Jun 19, 2011 12:21 pm

Hi,

I'm on a gentoo x64, I donwloaded the v2 x64 build 2065 and I can't run it.
I first had to compile libpng-1.2.44 as the version 1.4.5 is not supported, but yet I still can't run it...

I don't see what's wrong or missing. Any ideas?

Thanks.

Code: Select all
[0.89-519]guiohm@go1 ~/bin/Sublime_Text_2_Build_2065_x64 € . sublime_text
-bash: .: sublime_text: cannot execute binary file
[0.98-520]guiohm@go1 ~/bin/Sublime_Text_2_Build_2065_x64 € ldd sublime_text
   linux-vdso.so.1 =>  (0x00007fff48feb000)
   libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f36eb74c000)
   libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f36eb49c000)
   libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f36eb27a000)
   libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007f36eaf58000)
   libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f36ead2e000)
   libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f36eab21000)
   libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f36ea904000)
   libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f36ea607000)
   libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00007f36ea3e0000)
   libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f36ea195000)
   libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f36e9ef8000)
   libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f36e9cc2000)
   libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f36e9a75000)
   libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f36e9871000)
   libgthread-2.0.so.0 => /usr/lib64/libgthread-2.0.so.0 (0x00007f36e966c000)
   librt.so.1 => /lib64/librt.so.1 (0x00007f36e9463000)
   libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f36e914f000)
   libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f36e8f32000)
   libdl.so.2 => /lib64/libdl.so.2 (0x00007f36e8d2e000)
   libutil.so.1 => /lib64/libutil.so.1 (0x00007f36e8b2b000)
   libm.so.6 => /lib64/libm.so.6 (0x00007f36e88aa000)
   libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f36e856c000)
   libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/libstdc++.so.6 (0x00007f36e8259000)
   libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f36e8042000)
   libc.so.6 => /lib64/libc.so.6 (0x00007f36e7cdc000)
   libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f36e7ad5000)
   libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f36e78c5000)
   libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f36e76bc000)
   libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f36e74a9000)
   libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f36e729e000)
   libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f36e709b000)
   libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f36e6e98000)
   libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f36e6c8d000)
   libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f36e6a77000)
   libz.so.1 => /lib64/libz.so.1 (0x00007f36e685f000)
   libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f36e6636000)
   libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f36e63c3000)
   libEGL.so.1 => /usr/lib64/libEGL.so.1 (0x00007f36e61b2000)
   libpng14.so.14 => /usr/lib64/libpng14.so.14 (0x00007f36e5f8b000)
   libxcb-shm.so.0 => /usr/lib64/libxcb-shm.so.0 (0x00007f36e5d88000)
   libxcb-render.so.0 => /usr/lib64/libxcb-render.so.0 (0x00007f36e5b7f000)
   libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f36e5961000)
   libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f36e575d000)
   libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f36e5557000)
   libGL.so.1 => //usr/lib64/opengl/xorg-x11/lib/libGL.so.1 (0x00007f36e52da000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f36ebd64000)
   libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x00007f36e50d4000)
   libX11-xcb.so.1 => /usr/lib64/libX11-xcb.so.1 (0x00007f36e4ed2000)
   libxcb-glx.so.0 => /usr/lib64/libxcb-glx.so.0 (0x00007f36e4cbb000)
   libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007f36e4ab0000)
Last edited by guiohm on Sun Jun 19, 2011 4:55 pm, edited 1 time in total.
guiohm
 
Posts: 2
Joined: Sun Jun 19, 2011 12:13 pm

Re: V2 - Build 2065 - cannot execute binary file

Postby jps on Sun Jun 19, 2011 12:40 pm

Typing ". foo" in bash is the same typing "source foo", i.e., it'll try to interpret file "foo" as a shell script. You should be using "./foo" to execute foo, or in this case, "./sublime_text".
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: V2 - Build 2065 - cannot execute binary file

Postby guiohm on Sun Jun 19, 2011 4:55 pm

:oops: Woops, sorry. I don't know why I didn't saw this...

Of course it's working now.
Thanks!
guiohm
 
Posts: 2
Joined: Sun Jun 19, 2011 12:13 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 12 guests

cron