Home Download Buy Blog Forum Support

Build for html doesn't work

Build for html doesn't work

Postby ceej on Fri Aug 05, 2011 4:12 pm

It seems like build for html doesn't work http://screencast.com/t/CaNeXVAWKjbs
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: Build for html doesn't work

Postby iamntz on Fri Aug 05, 2011 5:12 pm

And you want to build... what? :roll:
iamntz
 
Posts: 909
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Build for html doesn't work

Postby ceej on Fri Aug 05, 2011 5:14 pm

I have an tag checker script so it makes sure you have matching opening and closing tags, plus I also have php inside so I like to run that too.
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: Build for html doesn't work

Postby jps on Fri Aug 05, 2011 11:05 pm

There is no build system for HTML that ships with Sublime Text.

If you're having issues with your custom build system, perhaps you'd be better off pointing out what issues you're having with it, and providing a listing of its contents.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Build for html doesn't work

Postby ceej on Fri Aug 05, 2011 11:40 pm

I created a custom one just the same way as I did for php and it works just fine. https://gist.github.com/b3080f9cf6ac09da9675 is the one I have for html
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: Build for html doesn't work

Postby jps on Fri Aug 05, 2011 11:47 pm

What's the issue that you're having? I'm going to assume that it's working fine when you explicitly set it as the build system, but not when the build system is set to Automatic.

If that's the case, then the issue is with your selector. On OS X, you can use alt+command+p to find the scope under the selection - it looks like you want text.html, rather than source.html
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Build for html doesn't work

Postby ceej on Sat Aug 06, 2011 12:04 am

There we go, thank you for that :) That command is useful to know :)
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 6 guests