Home Download Buy Blog Forum Support

OSX Bookmarks

OSX Bookmarks

Postby jbrooksuk on Thu Aug 11, 2011 8:57 am

Since I'm new to OSX, I might just be, being an idiot... So please excuse my ignorance :)

The toolbar shows that Toggle Bookmark is CMD+F2 however that does absolutely nothing for me. I don't get the brightness dialog, but I don't get a bookmark created either.

Thanks :)
jbrooksuk
 
Posts: 773
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: OSX Bookmarks

Postby jps on Thu Aug 11, 2011 9:17 am

You need to press fn+f2 to get an f2 key press on a apple laptop keyboard (so fn+cmd+f2)
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: OSX Bookmarks

Postby jbrooksuk on Thu Aug 11, 2011 9:24 am

jps wrote:You need to press fn+f2 to get an f2 key press on a apple laptop keyboard (so fn+cmd+f2)

That makes sense! Cheers Jon!
jbrooksuk
 
Posts: 773
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: OSX Bookmarks

Postby rlyeh on Thu Aug 11, 2011 9:47 am

Hmmm... I think my build got bookmarks broken.
using 2101 win64

steps to reproduce:
open a c++ file
click on line N, ie, 37
set a bookmark, ctrl+f2
click on line O, ie, 47
set a bookmark, ctrl+f2
click back on line N, ie, 37
toggle a bookmark, ctrl+f2, wont happen

it works ok if you navigate w/ keyboard. broken if using a mouse.
rlyeh
 
Posts: 8
Joined: Fri Jul 01, 2011 7:56 pm

Re: OSX Bookmarks

Postby jps on Thu Aug 11, 2011 10:56 am

Bookmarks record a specific position in the file, not just a line. Ctrl+F2 will always toggle a bookmark, but it may be adding a second bookmark to the line if the caret is in a different position than the original bookmark.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: OSX Bookmarks

Postby rlyeh on Thu Aug 11, 2011 1:50 pm

oh weird. ok, tried it but behaviour is not what i expect.

1st) toggle a bookmark in line 1, pos 10
2nd) toggle a bookmark in line 2, pos 20
3rd) toggle a bookmark in line 1, pos 30

pushing f2 now wont cycle sequentially after first loop. what im doing wrong?
rlyeh
 
Posts: 8
Joined: Fri Jul 01, 2011 7:56 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 23 guests