Home Download Buy Blog Forum Support

Help -- I can't type!

Re: Help -- I can't type!

Postby adzenith on Thu Aug 11, 2011 1:14 am

jps wrote:Just to be clear, for everyone who's had this, have you changed your ignored_packages setting (at any time) to enable Vintage?

Yeah, I had enabled Vintage for a little to try it out. I turned it back off and that's when the problem happened. Maybe the views got stuck in ro mode because I was in command mode when I turned Vintage off?
adzenith
 
Posts: 1216
Joined: Mon Oct 19, 2009 9:12 pm

Re: Help -- I can't type!

Postby jps on Thu Aug 11, 2011 1:27 am

When Vintage is enabled, it'll set the command_mode and inverse_caret_state settings on all views. When it's disabled, it removes these settings. However, if it doesn't get notified about being disabled, such as via Global.sublime-settings being modified when Sublime Text isn't running, then the settings will be left around.

I'll take a look at changing things such that these settings are never serialized.
jps
Site Admin
 
Posts: 3067
Joined: Wed Mar 19, 2008 12:33 pm

Re: Help -- I can't type!

Postby oats on Thu Aug 11, 2011 12:51 pm

I did not enable VI mode intentionally, and afterwards moved the package to the ignored packages folder, and even that didn't help. It is still not clear to me how I got in VI mode. What is the keystroke to enter/leave vintage mode? I didn't see anything in the key bindings.
oats
 
Posts: 101
Joined: Mon Nov 09, 2009 4:39 pm

Re: Help -- I can't type!

Postby ajpalkovic on Fri Aug 12, 2011 6:37 pm

Temporary solution:
1. Save and close the project
2. Edit the project file
3. Replace "command_mode": true with "command_mode": false
4. Replace "inverse_caret_state": true with "inverse_caret_state": false
5. Save the file
6. Reopen the project
ajpalkovic
 
Posts: 142
Joined: Fri Jun 10, 2011 10:21 pm

Re: Help -- I can't type!

Postby jbrooksuk on Mon Aug 15, 2011 1:44 pm

I experience this problem today on Lion.

Closing all buffers, quitting and then re-opening sorted it.

I don't remember ever enabling Vintage mode.
jbrooksuk
 
Posts: 773
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Previous

Return to General Discussion

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 27 guests