Home Download Buy Blog Forum Support

[Linux] Running Problem

[Linux] Running Problem

Postby Autarc on Thu Aug 18, 2011 1:03 am

Hio guys,

After I tried Sublime at WIndows, I decided that it would be a fair replacement for vim at at my working machine.
It runs Archlinux (64bit) and got awesome as a window manager. I thought it would be great that their is the current
package already in the repositry, but unfortunately
I'am getting an error message as try to execute sublime. Would be great if you could help me :|
(~ i thought it would be something with Python, but since I got Python 2.7 beside 3.2.1 - there shouldn't be any problem)

Traceback (most recent call last):
File "./PackageSetup.py", line 155, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 148, in upgradePackage
os.path.join(backupdir, base),inhibitOverwrite)
File "./PackageSetup.py", line 80, in upgradeArchive
writeFile(fname, newar.read(f))
File "./PackageSetup.py", line 18, in writeFile
with.opem(fname, 'wb') as fo:
IOError:[Erno 2] Datei oder Verzeichnis nicht gefunden: 'u/home/autarc/.config/sublime-text-2/packages/Default
Distraction Free.sublime-settings'

Moreover it would be good to know, where I could activate the dua panel/splitview mode and if there is already a plugin
- which compies/translates CoffeeScripter in JavaScript (~ featuring the second display, similar to this).

Thanks for your help :)
Posts: 4
Joined: Wed Aug 17, 2011 9:15 pm

Re: [Linux] Running Problem

Postby jps on Thu Aug 18, 2011 1:32 am

When Sublime Text starts up, it tries to extract the packages to your ~/.config/sublime-text-2 directory. The error message you're getting is indicating that it's unable to write to one of the files there ('home/autarc/.config/sublime-text-2/packages/Default/Distraction Free.sublime-settings').

You can try and verify that the directory exists and is writeable. If it was working in the past but has stopped working now, a reasonable option is to just delete the ~/.config/sublime-text-2 directory and start with a clean slate.
Site Admin
Posts: 3217
Joined: Wed Mar 19, 2008 12:33 pm

Re: [Linux] Running Problem

Postby Autarc on Thu Aug 18, 2011 10:40 pm

Thanks, re-setting the permision solved the problem :)
Posts: 4
Joined: Wed Aug 17, 2011 9:15 pm

Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], FichteFoll and 27 guests