Home Download Buy Blog Forum Support

Build file not building !!

Build file not building !!

Postby bwghughes on Mon Aug 22, 2011 12:39 pm

I've created the following build file:

Code: Select all
   "cmd": ["multimarkdown", "--to=html", "--output=$file_path/$file_base_name.html", "$file"],
   "selector": "source.md"

however, I get the following when I run the Build:

Code: Select all
[Errno 2] No such file or directory

In the console it reads:

Code: Select all
Running multimarkdown --to=html --output=/Users/<user>/Dropbox/Work/DWP/Process/AMM/AMM.html /Users/<user>/Dropbox/Work/DWP/Process/AMM/AMM.md

(<user> is intentionally replaced)
When I run that command on the command line, it runs successfully, however it does not run when initiated from the editor.

Any ideas?

Posts: 1
Joined: Mon Aug 22, 2011 12:34 pm

Re: Build file not building !!

Postby guillermooo on Mon Aug 22, 2011 1:07 pm

Use an absolute path in cmd. You're most likely getting that error because your shell's PATH and your system-wide PATH are different.

Also, you can use the "path" element in a build sys to add paths to the subprocess PATH, so you don't need to change your system settings.
Posts: 738
Joined: Thu Jul 23, 2009 9:06 am

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 26 guests