Home Download Buy Blog Forum Support

Bug or not?

Bug or not?

Postby genix on Sat Aug 27, 2011 11:13 am

Hello,

I'm not sure if it is a bug or a feature, but it is annoying :)

When I type $i in a PHP file the autocomplete is showing a list of snippets, after I type '=' ST2 is automatically inserting the highlighted snippet. Is it possible to make ST2 only insert snippets on Enter?

I am using a german keyboard layout, so to type '=' I have to use the key combination SHIFT+0.

Thanks.
genix
 
Posts: 5
Joined: Sun Aug 14, 2011 4:40 pm

Re: Bug or not?

Postby jbrooksuk on Sat Aug 27, 2011 3:00 pm

Do you have any plugins installed such as SublimeCodeIntel? That happens to me sometimes.
jbrooksuk
 
Posts: 689
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: Bug or not?

Postby genix on Sat Aug 27, 2011 4:54 pm

hmm, yes I have SublimeCodeIntel installed.
I tried it without SublimeCodeIntel, now if I type $i the autocomplete is not automatically shown, but on CTRL+Space.
When I then type '=' the same happens.

It would be create if there was an option, so that the snippet is only inserted on Enter key.
genix
 
Posts: 5
Joined: Sun Aug 14, 2011 4:40 pm

Re: Bug or not?

Postby genix on Sat Aug 27, 2011 8:38 pm

ok I solved it by adding this keybinding:

Code: Select all
{ "keys": ["="], "command": "hide_auto_complete", "context":
   [
      { "key": "auto_complete_visible", "operator": "equal", "operand": true }
   ]
}
genix
 
Posts: 5
Joined: Sun Aug 14, 2011 4:40 pm


Return to General Discussion

Who is online

Users browsing this forum: pete340 and 21 guests

cron