Home Download Buy Blog Forum Support

[SOLVED] Slow Rendering on Gentoo GNU/Linux with KDE

[SOLVED] Slow Rendering on Gentoo GNU/Linux with KDE

Postby ahmedtd on Tue Aug 30, 2011 1:10 am

I'm using Sublime Text 2 build 2095 under Gentoo Linux and KDE. For some reason, the rendering of the text buffer is annoyingly slow. In particular, scrolling the buffer exposes some very noticeable horizontal striping, and typed characters take a fraction of a second to appear.

I previously used Sublime 2 under Kubuntu, and it had the normal snappy and crisp experience, so it's most likely a problem with my system's configuration.

Are there any external dependencies that I might be missing? I had to install libpng1.2 in order to get Sublime to start, but I'm wondering if there might be something else that I'm missing that's causing Sublime to fall back to software rendering.
Last edited by ahmedtd on Sun Sep 04, 2011 7:40 am, edited 1 time in total.
ahmedtd
 
Posts: 4
Joined: Tue Aug 30, 2011 1:04 am

Re: Slow Rendering on Gentoo GNU/Linux with KDE

Postby jps on Tue Aug 30, 2011 1:41 am

S2 does indeed always use software rendering.

Two things to check:
- Do you have any plugins installed? Some can cause slowdowns.
- What color depth is your screen? S2 emits 32 bit RGB values, if you're screen is set to, say, 16 bit color depth, then the conversion may be hurting you.
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: Slow Rendering on Gentoo GNU/Linux with KDE

Postby ahmedtd on Tue Aug 30, 2011 8:11 pm

Hmm. Well, I've changed around the color depth settings in my xorg.conf, all the way up to 24-bit color depth, with no effect. If I go any higher, X informs me on startup that my hardware driver (i810) does not support it. However, on the same hardware running kubuntu, I didn't have this issue. I'm going to keep looking at my driver setup to see if I'm missing something.
ahmedtd
 
Posts: 4
Joined: Tue Aug 30, 2011 1:04 am

Re: Slow Rendering on Gentoo GNU/Linux with KDE

Postby ahmedtd on Sat Sep 03, 2011 6:25 pm

Well, as far as I can tell, it appears to be a regression in the newer versions of the intel driver for XFree86 or the kernel intel driver. They'e changed up the direct rendering system, and it's not fully optimized yet. So, it should go away with time.
ahmedtd
 
Posts: 4
Joined: Tue Aug 30, 2011 1:04 am

Re: Slow Rendering on Gentoo GNU/Linux with KDE

Postby ahmedtd on Sun Sep 04, 2011 7:39 am

I'm happy to report that moving to kernel 3.0.4 resolved this issue.
ahmedtd
 
Posts: 4
Joined: Tue Aug 30, 2011 1:04 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 11 guests