Home Download Buy Blog Forum Support

(most) key bindings not working, ubuntu 10, build 2110

(most) key bindings not working, ubuntu 10, build 2110

Postby chriscorwin on Wed Aug 31, 2011 12:12 pm

I'm having a tough time with keybindings in Sublime Text 2.

I'm currently on build 2110, though I've had this issue --- increasingly, it seems --- in builds leading up to this.

Most of my things don't seem to have key bindings anymore --- they've been.... disappearing?

Example: "Show/Hide Minimap".

I *swear* this used to have a keyboard shortcut.

But now I can't make it recognize one.


Things like "find in project" are a no-brainer for having a keyboard shortcut by default, right?

How/where does one go about doing this?

What is the syntax?

Perhaps I'm just getting that wrong?

But I don't think so: changes in my Sublime Keymap User file have zero effect: I can't make any changes there, it seems.

Help?


Perhaps I have things installed weird/wrong?

The linux installer just seems to kind of assume you know what to do with the .bz2 download -- and I've done what makes sense, but maybe I have things configured wrong?

Are there simple/known "gotchas" for installing to ubuntu that I've missed?

Thanks in advance for any help.

-- chris corwin
chriscorwin
 
Posts: 4
Joined: Wed Aug 31, 2011 12:05 pm

Re: (most) key bindings not working, ubuntu 10, build 2110

Postby jps on Wed Aug 31, 2011 1:30 pm

btw, neither Show/Hide Minimap nor Find in Project have key bindings. The latter just opens the Find in Files panel (with the location explicitly set to <open folders>) - generally you'd just use the Find in Files shortcut (Ctrl+Shift+F).

One key binding that has changed recently is Show/Hide Side Bar, which was Ctrl+B, but is now Ctrl+K,Ctrl+B - this isn't listed in the menu as GTK doesn't offer a way to display sequence key bindings AFAIK.

Take a look at sublimetext.info for some docs on the key bindings: http://sublimetext.info/docs/en/customi ... dings.html
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: (most) key bindings not working, ubuntu 10, build 2110

Postby chriscorwin on Wed Aug 31, 2011 4:15 pm

btw, neither Show/Hide Minimap nor Find in Project have key bindings. The latter just opens the Find in Files panel (with the location explicitly set to <open folders>) - generally you'd just use the Find in Files shortcut (Ctrl+Shift+F).


AHA!

That was totally non-obvious to me, though in retrospect, I'm unsure how I didn't figure it out.

hrm...


One key binding that has changed recently is Show/Hide Side Bar, which was Ctrl+B, but is now Ctrl+K,Ctrl+B - this isn't listed in the menu as GTK doesn't offer a way to display sequence key bindings AFAIK.


Now, see, I read the release notes for 2110, and how that binding had changed, but again, totally didn't get that it was a "two step process".

This does work for me.


Take a look at sublimetext.info for some docs on the key bindings: http://sublimetext.info/docs/en/customi ... dings.html


I have looked at this -- lots actually -- and something about how it's all written seems to sneak past my understanding, somehow.

I totally don't understand, for example, how I would create a key binding for (and this is something i want) "Project: Refresh Folders".

Is there some documentation that I just am not discovering on what the "commands" you *can* bind are that exist?

Please forgive me if all of this ought to be self-evident --- I may well just have a blind spot for this stuff.

:/

Thanks!
chriscorwin
 
Posts: 4
Joined: Wed Aug 31, 2011 12:05 pm

Re: (most) key bindings not working, ubuntu 10, build 2110

Postby chriscorwin on Wed Aug 31, 2011 5:09 pm

...and now I think I have started to sort it out, afterall.

I have this now:

Code: Select all
[
   { "keys": ["f5"], "command": "refresh_folder_list" },
   { "keys": ["ctrl+shift+f"], "command": "show_panel", "args": {"panel": "find_in_files", "location": "<open folders>"}},
   { "keys": ["ctrl+k", "ctrl+shift+f"], "command": "show_panel", "args": {"panel": "find_in_files", "location": "<redacted>/j2ee-apps/base/web-app.war"}}
]



...which appears to be working.

Thanks for getting me pointed in the right direction.
chriscorwin
 
Posts: 4
Joined: Wed Aug 31, 2011 12:05 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], subhaze, Yahoo [Bot] and 13 guests