Home Download Buy Blog Forum Support

Segmentation Fault

Segmentation Fault

Postby itsmewes on Sun Nov 13, 2011 11:44 am

I updated my ST2 2 days ago, but when I ran the update I can't open ST2 at all. When I try open it through terminal I get this message:
/usr/bin/sublime-text-2: line 2: 3823 Segmentation fault /usr/lib/sublime-text-2/sublime_text $*

I installed ST2 from the ppa at ppa:webupd8team/sublime-text-2.
I am running Ubuntu 11.10, 64 bit.

Thank you for your help.
itsmewes
 
Posts: 2
Joined: Sun Nov 13, 2011 11:31 am

Re: Segmentation Fault

Postby enberg on Mon Nov 14, 2011 9:12 am

I seem to be having the same problem. I, similarly, run Ubuntu 11.10 64 bit and have installed ST2 from the same ppa as OP.

When I try to run from a terminal I get the following error message:
/usr/bin/sublime-text-2: line 2: 4947 Segmentation fault /usr/lib/sublime-text-2/sublime_text $*
enberg
 
Posts: 1
Joined: Mon Nov 14, 2011 9:06 am

Re: Segmentation Fault

Postby itsmewes on Mon Nov 14, 2011 5:54 pm

I just installed the latest update from the ppa and it is working now.

I had been going through ST2 withdrawal :P
itsmewes
 
Posts: 2
Joined: Sun Nov 13, 2011 11:31 am

Re: Segmentation Fault

Postby akmur on Fri Nov 18, 2011 9:54 am

Hello guys I get the same! :(
using the same webupd8 ppa!

Any help?
akmur
 
Posts: 3
Joined: Fri Nov 18, 2011 9:53 am

Re: Segmentation Fault

Postby akmur on Fri Nov 18, 2011 3:33 pm

Same happens running the app I downloaded

./sublime_text
Segmentation fault
akmur
 
Posts: 3
Joined: Fri Nov 18, 2011 9:53 am

Re: Segmentation Fault

Postby akmur on Fri Nov 18, 2011 8:46 pm

does anybody have an older version on their hd?
an older version might work for us
akmur
 
Posts: 3
Joined: Fri Nov 18, 2011 9:53 am

Re: Segmentation Fault

Postby jps on Fri Nov 18, 2011 10:44 pm

Neither the current regular build nor the current dev build have this problem - it sounds like you're using an old dev build. I don't know the details with the PPA you're using, but if you use the version from http://www.sublimetext.com/2 it'll run for you.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Segmentation Fault

Postby addroof on Tue Apr 23, 2013 7:28 am

Hi,
I have this Segmentation Fault using "Sublime Text 2 Build 2217" on Ubuntu
Ubuntu 10.04.4 LTS (lucid) 64 bits

Both of PPA (webupd8team) and Download page (http://c758482.r82.cf2.rackcdn.com/Subl ... 64.tar.bz2) copies produce the same result.
But it is fine when I changed to the 32bits version (http://c758482.r82.cf2.rackcdn.com/Subl ... .1.tar.bz2) of sublime text 2

I started the sublime-text from the command line, after the program pops up, every key stroke (shift, alt, .......) produce 'Segmentation fault' and the sublime dies:

Below is the error message:
$ sublime-text
/usr/bin/sublime-text: line 3: 7590 Segmentation fault /usr/lib/sublime-text-2/sublime_text --class=sublime-text-2 "$@"

$ sublime-text
/usr/bin/sublime-text: line 3: 7931 Segmentation fault /usr/lib/sublime-text-2/sublime_text --class=sublime-text-2 "$@"

$ sublime-text
/usr/bin/sublime-text: line 3: 7947 Segmentation fault /usr/lib/sublime-text-2/sublime_text --class=sublime-text-2 "$@"

$ sublime-text
/usr/bin/sublime-text: line 3: 8596 Segmentation fault /usr/lib/sublime-text-2/sublime_text --class=sublime-text-2 "$@"

$ sublime-text
/usr/bin/sublime-text: line 3: 8656 Segmentation fault /usr/lib/sublime-text-2/sublime_text --class=sublime-text-2 "$@"
addroof
 
Posts: 1
Joined: Tue Apr 23, 2013 7:11 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 22 guests