Home Download Buy Blog Forum Support

Sublime converts my accented characters to '?'.

Sublime converts my accented characters to '?'.

Postby yngve on Wed Nov 23, 2011 7:54 am

Hi,

When opening a file containing accented letters, for example 'å' and '©', it displays as '?'. I guess this has something to do with code page or encoding since the file is ANSI. The system code page is Windows (1252). I have tried to explicitly reopen the file in this encoding, but it doesn't help.

I don't really have a problem with the letters displaying as '?'. What I don't expect is for Sublime to store these question marks to file when saving. I expect it to store the same bytes it read.
It would be nice if Sublime would let me see the actual letters and let me write these accented letters. Note that it does let me write these accented letters, but I don't trust it to write the correct bytes when saving those letters to file.

My system:
Win 7 Pro x64
Sublime Text 2 x64 (build 2139)
yngve
 
Posts: 2
Joined: Wed Nov 23, 2011 7:42 am

Re: Sublime converts my accented characters to '?'.

Postby wbond on Wed Nov 23, 2011 3:02 pm

If you are getting questions marks, this almost certainly indicates that there is an issue with interpreting the file according to the encoding specified. Perhaps try opening using some other encodings?
wbond
 
Posts: 493
Joined: Mon Feb 28, 2011 5:33 am

Re: Sublime converts my accented characters to '?'.

Postby yngve on Thu Nov 24, 2011 7:06 am

It seems you are right. I am able to open the file now correctly. I think I might have accidentally tested all the encodings on a already botched file.

My point still stands about sublime saving those question marks to file. I would have thought that it displays question marks when it recognize the letters, but not modify the opened file, replacing these letters with question marks.

Also: How can I determine which encoding a file is currently opened with?

Thanks!
yngve
 
Posts: 2
Joined: Wed Nov 23, 2011 7:42 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 18 guests