Home Download Buy Blog Forum Support

Find in Files behaviour inconsistent

Find in Files behaviour inconsistent

Postby Cottser on Thu Nov 24, 2011 7:28 pm

First of all, thank you for Sublime Text 2. It is wonderful.

This may or may not be related to viewtopic.php?f=3&t=3807

Find (and replace) in Files seems to have inconsistent results, it seems to work the best locally but also works sometimes over a remote FTP server mounted via Transmit Disk and on mounted network volumes (SMB). When it doesn't work (I've seen the inconsistent behaviour both locally, FTP, and SMB), it only finds a small fraction of the results compared to what it should.

What I'm expecting:
Searching 158 files for "foo"
[…]
128 matches across 65 files

What I sometimes get:
Searching 158 files for "foo"
[…]
15 matches across 8 files

Running ack from the terminal seems to be consistent. The only options I have enabled are "Show Context" and "Use Buffer", and I've tried leaving "Where:" to just Open files and folders as well as specifying the path there.

If I copy the FTP contents to my local drive, I seem to get different results whether I copy via Transmit or via Transmit Disk. If I copy via Transmit Disk, I seem to be getting the limited results, but copying via Transmit seems to work fine. I'm not sure if either process does anything differently as far as line endings or permissions.
Cottser
 
Posts: 22
Joined: Sat Oct 08, 2011 12:24 am

Re: Find in Files behaviour inconsistent

Postby jps on Fri Nov 25, 2011 7:36 am

When searching, do you get any messages in the console about skipping binary files?
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: Find in Files behaviour inconsistent

Postby Cottser on Fri Nov 25, 2011 2:22 pm

Yes, 65 of those warnings.
Cottser
 
Posts: 22
Joined: Sat Oct 08, 2011 12:24 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 16 guests